1

During grub boot, I have to add nomodeset parameter, else Kali Linux 2020.2 won't be able to boot inside VirtualBox.

Then, I was trying to install nvidia drivers on VM when found this article.

Do not attempt this in a VM. It is possible in theory, however this likely will not work and we do not recommend that users attempt this.

https://www.kali.org/docs/general-use/install-nvidia-drivers-on-kali-linux/

I notice that vga detected in guest OS (Kali) is VMware SVGA II Adapter while the host OS is using NVIDIA

Guest OS

kali@kali:~$ lspci | grep -i vga
00:02.0 VGA compatible controller: VMware SVGA II Adapter
kali@kali:~$ 

Host OS

wolf@linux:~$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Device 3e9b
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)
wolf@linux:~$ 

If the driver not installed, I have to add nomodeset parameter every time during boot process.

How do I fix this problem permanently?

1
  • why is your question tagged virtualbox, nvidia and graphic-card when it is not about any of those things ... your question is about grub configuration and 95% of your post is not even related to the actual question
    – jsotola
    May 17, 2020 at 7:46

1 Answer 1

0

I've run into the same issue with a Kali VM in ESXi.

In order to edit the GRUB config so that you don't have to manually enter the nomodeset option on each boot, you can:

sudo nano /etc/default/grub

and then add nomodeset to GRUB_CMDLINE_LINUX_DEFAULT:

GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX=""

And then save by hitting Ctrl+O, then exit nano with Ctrl+X, then simply run:

sudo update-grub

However I've found that doing so leaves me with particularly small resolution options for the VM. I attempted to edit the resolution options using xrandr, but still have not had success. If anyone knows how to resolve that, I'd be happy to hear about it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.