0

I created a few snapshots with virsh snapshot-create-as --name "yyyymmdd-snap.qcow2 --disk-only --domain my-vm.qcow2 and made a bit of a mess with the snapshot image filenames. It appears that appending .qcow2 causes it to chain the spanshot filenames like:

my-vm.qcow2
my-vm.yyyymmdd-snap.qcow2
my-vm.yyyymmdd-snap.yyyymmdd-snap.qcow2
my-vm.yyyymmdd-snap.yyyymmdd-snap.yyyymmdd-snap.qcow2
....

Ideally, I'd like to see:

my-vm.qcow2
my-vm.yyyymmdd-snap.qcow2
my-vm.yyyymmdd-snap.qcow2
my-vm.yyyymmdd-snap.qcow2
....

I know now to create snapshots without .qcow2 in the future, but how I can clean up the current snapshot filenames without breaking my VM?

EDIT

Apparently, appending .qcow2 isn't what caused the filename chaining. I don't know why it did that.

1 Answer 1

0

I dont know with qcow2, but for VMware snapshots the images has the name of the parent disk on the first lines of the file, if you change them you can rename the snapshot name also.

Second option, merge them: https://blog.programster.org/qemu-img-cheatsheet

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .