0

I am using Gentoo (for the first time, actually). I am trying to set up package management. I discovered that I have to set up portage (emerge). While doing so, I had to run emerge --sync. That gave the message:

Use eselect news read to view items.

I tried that, but I got: zsh: command not found: eselect

I discovered a package: app-admin/eselect, so I tried:

emerge --ask app-admin/select

Then I get:

!!! /etc/portage/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)


!!! Your current profile is invalid. If you have just changed your profile
!!! configuration, you should revert back to the previous configuration.
!!! Allowed actions are limited to --help, --info, --search, --sync, and
!!! --version.

Update:

Turns out I was mistaken. I thought I was working in a flavour of gentoo, and so I was trying to setup portage manually, since the emerge command turned out to be missing.

Turns out, I was working in a flavour of CentOS, and so yum was what I needed to use. I had downloaded and un-tarred a portage tarball into a CentOS flavour, which explains why eselect was not there, and in turn explains why I had that sort of weird chicken & egg like problem between the emerge and eselect commands.

As per Andy Dalton's answer, I was yesterday looking at manually creating the make.profile symlink myself, to some file under /usr/portage/profiles/, but I was having a hard time figuring out which file to link it to.

Anyway, I got yum working, and I'm not sure what would happen if I went in to get portage working too. That could probably lead to some sort of package management conflict issues, so I'm not sure I want to experiment with that.

2
  • Are you following the handbook? If so, you missed some steps: wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Base (see eselect profile list/eselect profile set) – Andy Dalton May 16 '20 at 2:49
  • @Andy Dalton: Yeah, my bad, turns out I was in a cent-os based environment, not a gentoo one, see my answer below for full clarification on that. – user904542 May 16 '20 at 14:51
0

Normally during installation you'd use eselect profile list to view profiles and eselect profile set to select one. I'm not sure why you currently don't have eselect --- normally it would be /usr/bin/eselect, but if you don't you can try doing what eselect profile set would have done.

My profiles are located here:

$ find /usr/portage/profiles/default/linux/amd64/17.1 -type d
/usr/portage/profiles/default/linux/amd64/17.1
/usr/portage/profiles/default/linux/amd64/17.1/systemd
/usr/portage/profiles/default/linux/amd64/17.1/selinux
/usr/portage/profiles/default/linux/amd64/17.1/desktop
/usr/portage/profiles/default/linux/amd64/17.1/desktop/gnome
/usr/portage/profiles/default/linux/amd64/17.1/desktop/gnome/systemd
/usr/portage/profiles/default/linux/amd64/17.1/desktop/plasma
/usr/portage/profiles/default/linux/amd64/17.1/desktop/plasma/systemd
/usr/portage/profiles/default/linux/amd64/17.1/no-multilib
/usr/portage/profiles/default/linux/amd64/17.1/no-multilib/hardened
/usr/portage/profiles/default/linux/amd64/17.1/no-multilib/hardened/selinux
/usr/portage/profiles/default/linux/amd64/17.1/developer
/usr/portage/profiles/default/linux/amd64/17.1/hardened
/usr/portage/profiles/default/linux/amd64/17.1/hardened/selinux

You'll have to select which profile you want to use; I'm using the default/linux/amd64/17.1/systemd. Be sure to read the manual and understand what you pick here.

If I wanted to select that profile manually, then I'd do:

# cd /etc/portage
# ln -s ../../usr/portage/profiles/default/linux/amd64/17.1/systemd make.profile

One you've done that, then hopefully emerge --ask eselect will be successful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.