3

I followed this https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_17_-.3E_Fedora_18 guide to upgrade my Fedora 17 to 18.

All was fine until I issued su -c 'yum --releasever=18 --disableplugin=presto distro-sync -y'. My PuTTY disconnected. Obviously it is because Cleanup: openssh-server-5.9p1-22.fc17.x86_64 306/574

How can I skip OpenSSH during the distro-sync so my upgrade works fine?

  • 2
    yum has a --exclude=[package] option which exclude package from updating, but not sure if it works with distro-sync. anyway, even if it works, will openssh-server-fc17 works on Fedora 18? remotely upgrade is some kind of dangerous which can cause out of control – LiuYan 刘研 Dec 17 '12 at 4:38
  • I issue su -c 'yum --releasever=18 --disableplugin=presto --exclude=openssh* distro-sync -y' its succeed until end of the process after reboot what @LiuYan刘研 worried about is true. openssh-server-fc17 NOT working on Fedora 18. – RiseCakoPlusplus Dec 17 '12 at 5:54
3

Install a separate ssh daemon - either another copy of OpenSSH or e.g. Dropbear - into the system, possibly into /opt or $HOME, run it on a different port. Also run the update in a virtual terminal multiplexer (tmux, screen..) to prevent troubles resulting from losing/dropping the connection halfway through the upgrade.

Using statically linked binaries for both the extra ssh daemon and the virtual terminal multiplexer would make sense as well in this case.

| improve this answer | |
0

I would also reccomend running inside a screen or tmux session. However, have you ever looked at FedUp to upgrade from F17 to F18? I gave it a try to upgrade my system, entirely remotely, and it worked.

| improve this answer | |
0

Why cant you use fedup or preupgrade followed by upgrade? These are standard upgrade methods.

Fedora update = fedup.

| improve this answer | |
0

I had to deal with this since upgrade form F15. Just upgrade openssh-server beforehand:

yum -y remove openssh-server\
&& yum -y --releasever=18 install openssh-server\
&& service sshd restart

You can do it safely over ssh. And then you can run the upgrade as usual:

yum -y --releasever=18 --disableplugin=presto distro-sync
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.