1

Let's say I have a Debian 10 VPS server, which does not have a lot of storage (20 GB). I use this server for various things, such as web server, automation platform, and such.

For some reasons, I'd want to install a specific version of Python, let's say the 3.6. However, when I try to run an apt install python3.6, here is the huge output that the command provides me:

root@labdebian10:~ # apt install python3.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'python3.6-kdtree-dbg' for regex 'python3.6'
Note, selecting 'python3.6-cups' for regex 'python3.6'
Note, selecting 'python3.6-ldap' for regex 'python3.6'
Note, selecting 'python3.6-cairo' for regex 'python3.6'
Note, selecting 'python3.6-sfml' for regex 'python3.6'
Note, selecting 'python3.6-pymad-dbg' for regex 'python3.6'
Note, selecting 'python3.6-nss' for regex 'python3.6'
Note, selecting 'python3.6-pypcap' for regex 'python3.6'
Note, selecting 'python3.6-2to3' for regex 'python3.6'
Note, selecting 'python3.6-urwid' for regex 'python3.6'
Note, selecting 'python3.6-silo' for regex 'python3.6'
Note, selecting 'python3.6-gevent-dbg' for regex 'python3.6'
Note, selecting 'python3.6-prelude' for regex 'python3.6'
Note, selecting 'python3.6-smbus' for regex 'python3.6'
Note, selecting 'python3.6-btrees' for regex 'python3.6'
Note, selecting 'python3.6-radix' for regex 'python3.6'
Note, selecting 'python3.6-subvertpy' for regex 'python3.6'
Note, selecting 'python3.6-smbc' for regex 'python3.6'
Note, selecting 'libpython3.6-stdlib' for regex 'python3.6'
Note, selecting 'python3.6-ldap-dbg' for regex 'python3.6'
Note, selecting 'python3.6-indexed-gzip' for regex 'python3.6'
Note, selecting 'python3.6-grpcio' for regex 'python3.6'
Note, selecting 'python3.6-yenc' for regex 'python3.6'
Note, selecting 'python3.6-crypto' for regex 'python3.6'
Note, selecting 'python3.6-tango' for regex 'python3.6'
Note, selecting 'python3.6-gevent' for regex 'python3.6'
Note, selecting 'python3.6-kdtree' for regex 'python3.6'
Note, selecting 'python3.6-casacore' for regex 'python3.6'
Note, selecting 'python3.6-pyodbc' for regex 'python3.6'
Note, selecting 'python3.6-blist' for regex 'python3.6'
Note, selecting 'python3.6-jpype' for regex 'python3.6'
Note, selecting 'python3.6-pyxattr-dbg' for regex 'python3.6'
Note, selecting 'python3.6-pymad' for regex 'python3.6'
Note, selecting 'python3.6-newt' for regex 'python3.6'
Note, selecting 'python3.6-pyisomd5sum' for regex 'python3.6'
Note, selecting 'python3.6-zodbpickle' for regex 'python3.6'
Note, selecting 'python3.6-rpy2' for regex 'python3.6'
Note, selecting 'python3.6-pyraf' for regex 'python3.6'
Note, selecting 'python3.6-crypto-dbg' for regex 'python3.6'
Note, selecting 'python3.6-pyalsa' for regex 'python3.6'
Note, selecting 'python3.6-bluez' for regex 'python3.6'
Note, selecting 'python3.6-pyaudio' for regex 'python3.6'
Note, selecting 'python3.6-icu-dbg' for regex 'python3.6'
Note, selecting 'python3.6-http-parser' for regex 'python3.6'
Note, selecting 'python3.6-selinux' for regex 'python3.6'
Note, selecting 'python3.6-kyotocabinet' for regex 'python3.6'
Note, selecting 'python3.6-wheezy.template' for regex 'python3.6'
Note, selecting 'python3.6-qrencode' for regex 'python3.6'
Note, selecting 'python3.6-deltarpm' for regex 'python3.6'
Note, selecting 'python3.6-zope.interface' for regex 'python3.6'
Note, selecting 'python3.6-pyxattr' for regex 'python3.6'
Note, selecting 'python3.6-gssapi' for regex 'python3.6'
Note, selecting 'python3.6-sendfile-dbg' for regex 'python3.6'
Note, selecting 'python3.6-ftdi1' for regex 'python3.6'
Note, selecting 'python3.6-cairo-dbg' for regex 'python3.6'
Note, selecting 'python3.6-hid' for regex 'python3.6'
Note, selecting 'python3.6-sane' for regex 'python3.6'
Note, selecting 'python3.6-icu' for regex 'python3.6'
Note, selecting 'python3.6-jpy' for regex 'python3.6'
Note, selecting 'python3-blist' instead of 'python3.6-blist'
Note, selecting 'python3-deltarpm' instead of 'python3.6-deltarpm'
Note, selecting 'python3-grpcio' instead of 'python3.6-grpcio'
Note, selecting 'python3-smbus' instead of 'python3.6-smbus'
Note, selecting 'python3-indexed-gzip' instead of 'python3.6-indexed-gzip'
Note, selecting 'python3-pyisomd5sum' instead of 'python3.6-pyisomd5sum'
Note, selecting 'python3-jpy' instead of 'python3.6-jpy'
Note, selecting 'python3-ftdi1' instead of 'python3.6-ftdi1'
Note, selecting 'python3-kdtree' instead of 'python3.6-kdtree'
Note, selecting 'python3-kdtree-dbg' instead of 'python3.6-kdtree-dbg'
Note, selecting 'python3-prelude' instead of 'python3.6-prelude'
Note, selecting 'python3-selinux' instead of 'python3.6-selinux'
Note, selecting 'python3-newt' instead of 'python3.6-newt'
Note, selecting 'python3-sane' instead of 'python3.6-sane'
Note, selecting 'python3-radix' instead of 'python3.6-radix'
Note, selecting 'python3-bluez' instead of 'python3.6-bluez'
Note, selecting 'python3-cairo' instead of 'python3.6-cairo'
Note, selecting 'python3-cairo-dbg' instead of 'python3.6-cairo-dbg'
Note, selecting 'python3-icu' instead of 'python3.6-icu'
Note, selecting 'python3-icu-dbg' instead of 'python3.6-icu-dbg'
Note, selecting 'python3-pymad' instead of 'python3.6-pymad'
Note, selecting 'python3-pymad-dbg' instead of 'python3.6-pymad-dbg'
Note, selecting 'python3-pyodbc' instead of 'python3.6-pyodbc'
Note, selecting 'python3-pyraf' instead of 'python3.6-pyraf'
Note, selecting 'python3-sendfile-dbg' instead of 'python3.6-sendfile-dbg'
Note, selecting 'python3-smbc' instead of 'python3.6-smbc'
Note, selecting 'python3-tango' instead of 'python3.6-tango'
Note, selecting 'python3-btrees' instead of 'python3.6-btrees'
Note, selecting 'python3-casacore' instead of 'python3.6-casacore'
Note, selecting 'python3-crypto' instead of 'python3.6-crypto'
Note, selecting 'python3-crypto-dbg' instead of 'python3.6-crypto-dbg'
Note, selecting 'python3-cups' instead of 'python3.6-cups'
Note, selecting 'python3-gevent' instead of 'python3.6-gevent'
Note, selecting 'python3-gevent-dbg' instead of 'python3.6-gevent-dbg'
Note, selecting 'python3-gssapi' instead of 'python3.6-gssapi'
Note, selecting 'python3-hid' instead of 'python3.6-hid'
Note, selecting 'python3-http-parser' instead of 'python3.6-http-parser'
Note, selecting 'python3-jpype' instead of 'python3.6-jpype'
Note, selecting 'python3-kyotocabinet' instead of 'python3.6-kyotocabinet'
Note, selecting 'python3-ldap' instead of 'python3.6-ldap'
Note, selecting 'python3-ldap-dbg' instead of 'python3.6-ldap-dbg'
Note, selecting 'python3-nss' instead of 'python3.6-nss'
Note, selecting 'python3-pyalsa' instead of 'python3.6-pyalsa'
Note, selecting 'python3-pyaudio' instead of 'python3.6-pyaudio'
Note, selecting 'python3-pypcap' instead of 'python3.6-pypcap'
Note, selecting 'python3-pyxattr' instead of 'python3.6-pyxattr'
Note, selecting 'python3-pyxattr-dbg' instead of 'python3.6-pyxattr-dbg'
Note, selecting 'python3-qrencode' instead of 'python3.6-qrencode'
Note, selecting 'python3-sfml' instead of 'python3.6-sfml'
Note, selecting 'python3-wheezy.template' instead of 'python3.6-wheezy.template'
Note, selecting 'python3-yenc' instead of 'python3.6-yenc'
Note, selecting 'python3-rpy2' instead of 'python3.6-rpy2'
Note, selecting 'python3-silo' instead of 'python3.6-silo'
Note, selecting 'python3-subvertpy' instead of 'python3.6-subvertpy'
Note, selecting 'python3-urwid' instead of 'python3.6-urwid'
Note, selecting 'python3-zodbpickle' instead of 'python3.6-zodbpickle'
Note, selecting 'python3-zope.interface' instead of 'python3.6-zope.interface'
python3-zope.interface is already the newest version (4.3.2-1+b2).
python3-zope.interface set to manually installed.
The following additional packages will be installed:
  acl adwaita-icon-theme at-spi2-core autoconf automake autotools-dev binutils binutils-common
  binutils-x86-64-linux-gnu blt build-essential bzip2 bzip2-doc ca-certificates-java casacore-data casacore-data-igrf
  casacore-data-jpl-de200 casacore-data-jpl-de405 casacore-data-lines casacore-data-observatories
  casacore-data-sources casacore-data-tai-utc cpp cpp-8 cython3 dbus-user-session dconf-gsettings-backend
  dconf-service default-jre default-jre-headless dh-python dpkg-dev fakeroot fontconfig fontconfig-config
  fonts-dejavu-core fonts-dejavu-extra g++ g++-8 gcc gcc-8 gdb gfortran gfortran-8 glib-networking
  glib-networking-common glib-networking-services gsettings-desktop-schemas gtk-update-icon-cache hicolor-icon-theme
  i2c-tools ibverbs-providers icu-devtools iraf iraf-noao java-common javascript-common libaec0 libalgorithm-diff-perl
  libalgorithm-diff-xs-perl libalgorithm-merge-perl libapr1 libaprutil1 libasan5 libasound2 libasound2-data
  libasyncns0 libatk-bridge2.0-0 libatk-wrapper-java libatk-wrapper-java-jni libatk1.0-0 libatk1.0-data libatomic1
  libatspi2.0-0 libauthen-sasl-perl libbabeltrace1 libbinutils libblas-dev libblas3 libbluetooth3
  libboost-python1.67.0 libbz2-1.0 libbz2-dev libc-ares2 libc-dev-bin libc6-dbg libc6-dev libcaf-openmpi-3
  libcairo-gobject2 libcairo2 libcasa-casa3 libcasa-coordinates3 libcasa-fits3 libcasa-images3 libcasa-lattices3
  libcasa-measures3 libcasa-mirlib3 libcasa-ms3 libcasa-python3-3 libcasa-scimath-f3 libcasa-scimath3 libcasa-tables3
  libcc1-0 libcfitsio7 libcminpack1 libcoarrays-dev libcoarrays-openmpi-dev libcolord2 libcos4-2 libcroco3 libcups2
  libdata-dump-perl libdatrie1 libdconf1 libdpkg-perl libdrm-amdgpu1 libdrm-common libdrm-intel1 libdrm-nouveau2
  libdrm-radeon1 libdrm2 libdw1 libencode-locale-perl libepoxy0 liberfa1 libevent-2.1-6 libevent-core-2.1-6
  libevent-pthreads-2.1-6 libexif12 libexpat1 libexpat1-dev libfabric1 libfakeroot libfftw3-double3 libfftw3-single3
  libfile-basedir-perl libfile-desktopentry-perl libfile-fcntllock-perl libfile-listing-perl libfile-mimeinfo-perl
  libflac8 libfont-afm-perl libfontconfig1 libfontenc1 libfribidi0 libftdi1-2 libfuntools1 libgail-common libgail18
  libgcc-8-dev libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgfortran-8-dev libgfortran5
  libgif7 libgl1 libgl1-mesa-dri libglapi-mesa libglvnd0 libglx-mesa0 libglx0 libgphoto2-6 libgphoto2-l10n
  libgphoto2-port12 libgraphite2-3 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2.0-0 libgtk2.0-bin libgtk2.0-common
  libharfbuzz0b libhdf5-openmpi-103 libhidapi-hidraw0 libhidapi-libusb0 libhtml-form-perl libhtml-format-perl
  libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl
  libhttp-message-perl libhttp-negotiate-perl libhwloc-dev libhwloc-plugins libhwloc5 libi2c0 libibverbs-dev
  libibverbs1 libice6 libicu-dev libicu63 libieee1284-3 libimagequant0 libio-html-perl libio-socket-ssl-perl
  libio-stringy-perl libipc-system-simple-perl libipt2 libisl19 libitm1 libjack-jackd2-0 libjansson4 libjbig0
  libjpeg-dev libjpeg62-turbo libjpeg62-turbo-dev libjs-jquery libjs-jquery-datatables libjson-glib-1.0-0
  libjson-glib-1.0-common libkyotocabinet16v5 liblapack-dev liblapack3 liblcms2-2 libldb1 libllvm7 liblog4tango5v5
  liblsan0 libltdl-dev libltdl7 liblwp-mediatypes-perl liblwp-protocol-https-perl liblzma-dev liblzo2-2 libmad0
  libmailtools-perl libmariadb3 libmpc3 libmpfr6 libmpx2 libncurses-dev libncurses5-dev libncurses6 libncursesw6
  libnet-dbus-perl libnet-http-perl libnet-smtp-ssl-perl libnl-3-200 libnl-3-dev libnl-route-3-200 libnl-route-3-dev
  libnorm1 libnspr4 libnss3 libnuma-dev libnuma1 libodbc1 libogg0 libomniorb4-2 libomnithread4 libopenal-data
  libopenal1 libopenmpi-dev libopenmpi3 libopus0 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpaper-utils
  libpaper1 libpcap0.8 libpciaccess0 libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5 libpcsclite1 libpgm-5.2-0
  libpixman-1-0 libpmix2 libpng-dev libpng-tools libportaudio2 libprelude23 libpreludecpp8 libproxy1v5
  libpsm-infinipath1 libpsm2-2 libpulse0 libpython3-dbg libpython3-dev libpython3.7 libpython3.7-dbg libpython3.7-dev
  libpython3.7-minimal libpython3.7-stdlib libqrencode4 libquadmath0 librdmacm1 libreadline-dev librest-0.7-0
  librsvg2-2 librsvg2-common libsamplerate0 libsane libsane-common libsensors-config libsensors5 libserf-1-1
  libsfml-audio2.5 libsfml-graphics2.5 libsfml-network2.5 libsfml-system2.5 libsfml-window2.5 libsigsegv2 libsiloh5-0
  libsm6 libsmbclient libsndfile1 libsndio7.0 libsnmp-base libsnmp30 libsodium23 libsoup-gnome2.4-1 libsoup2.4-1
  libstarlink-ast-err0 libstarlink-ast0 libstarlink-pal0 libstdc++-8-dev libsvn1 libsz2 libtalloc2 libtango9 libtcl8.6
  libtdb1 libtevent0 libthai-data libthai0 libtie-ixhash-perl libtiff5 libtimedate-perl libtinfo6 libtk-img libtk8.6
  libtool libtry-tiny-perl libtsan0 libubsan1 liburi-perl libutempter0 libutf8proc2 libvorbis0a libvorbisenc2
  libvorbisfile3 libwayland-client0 libwayland-cursor0 libwayland-egl1 libwbclient0 libwcs6 libwcstools1 libwebp6
  libwebpdemux2 libwebpmux3 libwww-perl libwww-robotrules-perl libx11-protocol-perl libx11-xcb1 libx86-1 libxaw7
  libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-sync1
  libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxft2 libxi6 libxinerama1 libxkbcommon0 libxml-parser-perl
  libxml-twig-perl libxml-xpathengine-perl libxmu6 libxpa1 libxpm4 libxrandr2 libxrender1 libxshmfence1 libxslt1.1
  libxss1 libxt6 libxtst6 libxv1 libxxf86dga1 libxxf86vm1 libzmq5 linux-libc-dev m4 make manpages-dev mariadb-common
  mysql-common ocl-icd-libopencl1 openjdk-11-jre openjdk-11-jre-headless openmpi-bin openmpi-common patch pkg-config
  prelude-utils python-talloc python3-astropy python3-atomicwrites python3-attr python3-dbg python3-decorator
  python3-dev python3-greenlet python3-greenlet-dbg python3-ipython python3-ipython-genutils python3-jinja2
  python3-markupsafe python3-more-itertools python3-numpy python3-olefile python3-persistent python3-pexpect
  python3-pickleshare python3-pil python3-pluggy python3-ply python3-prompt-toolkit python3-psutil python3-ptyprocess
  python3-py python3-pyasn1 python3-pyasn1-modules python3-pygments python3-pytest python3-pytest-arraydiff
  python3-pytest-astropy python3-pytest-doctestplus python3-pytest-openfiles python3-pytest-remotedata python3-scipy
  python3-sendfile python3-simplegeneric python3-stsci.tools python3-tk python3-traitlets python3-wcwidth python3.7
  python3.7-dbg python3.7-dev python3.7-minimal r-base-core r-base-dev r-cran-boot r-cran-class r-cran-cluster
  r-cran-codetools r-cran-foreign r-cran-kernsmooth r-cran-lattice r-cran-mass r-cran-matrix r-cran-mgcv r-cran-nlme
  r-cran-nnet r-cran-rpart r-cran-spatial r-cran-survival r-doc-html r-recommended read-edid samba-libs sane-utils
  saods9 saods9-doc tango-common tcl tcl-signal tcl-tls tcl-xpa tcl8.6 tcliis tcllib tclxml tk tk-html1 tk-mpeg
  tk-table tk8.6 tk8.6-blt2.5 tkblt tkcon tksao unzip update-inetd x11-common x11-utils x11-xserver-utils xbitmaps
  xdg-utils xterm zip zlib1g-dev
Suggested packages:
  autoconf-archive gnu-standards autoconf-doc gettext binutils-doc blt-demo casacore-data-eop casacore-data-predict
  cpp-doc gcc-8-locales cython-doc debian-keyring g++-multilib g++-8-multilib gcc-8-doc libstdc++6-8-dbg gcc-multilib
  flex bison gcc-doc gcc-8-multilib libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg libasan5-dbg liblsan0-dbg
  libtsan0-dbg libubsan1-dbg libmpx2-dbg libquadmath0-dbg gdb-doc gdbserver gfortran-multilib gfortran-doc
  gfortran-8-multilib gfortran-8-doc libgfortran5-dbg libi2c-dev python-smbus iraf-dev apache2 | lighttpd | httpd
  libasound2-plugins alsa-utils libgssapi-perl liblapack-doc glibc-doc colord cups-common git bzr libfftw3-bin
  libfftw3-dev libgd-tools gphoto2 gvfs libhwloc-contrib-plugins icu-doc jackd2 liblcms2-utils libtool-doc
  libcrypt-ssleay-perl liblzma-doc ncurses-doc libmyodbc odbc-postgresql tdsodbc unixodbc-bin openmpi-doc opus-tools
  pcscd pulseaudio readline-doc librsvg2-bin hplip lm-sensors sndiod snmp-mibs-downloader libstdc++-8-doc
  libtk-img-doc gcj-jdk libauthen-ntlm-perl libunicode-map8-perl libunicode-string-perl xml-twig-tools m4-doc make-doc
  opencl-icd fonts-ipafont-gothic fonts-ipafont-mincho fonts-wqy-microhei | fonts-wqy-zenhei fonts-indic ed
  diffutils-doc libxml2-utils python-astropy-doc python3-astropy-affiliated python3-beautifulsoup python3-h5py
  python3-matplotlib python3-pandas python3-yaml python-attr-doc python-crypto-doc python-gevent-doc
  python-greenlet-doc python-greenlet-dev python-gssapi-doc python-jinja2-doc python-numpy-doc python3-numpy-dbg
  python-persistent-doc python-pexpect-doc python-pil-doc python3-pil-dbg python-ply-doc python-psutil-doc subversion
  python-pyaudio-doc python-pygments-doc ttf-bitstream-vera genisoimage ipython3 python-pyxattr-doc python-rpy-docs
  python3-sane-dbg python-scipy-doc tix python3-tk-dbg python-urwid-doc python-yenc-doc python3.7-venv python3.7-doc
  python3-gdbm-dbg binfmt-support ess r-doc-info | r-doc-pdf r-mathlib r-base-html texlive-base texlive-latex-base
  texlive-generic-recommended texlive-fonts-recommended texlive-fonts-extra texlive-extra-utils
  texlive-latex-recommended texlive-latex-extra texinfo mozilla | www-browser unpaper python3-pyds9 xpa-tools
  tcl-tclreadline tcllib-critcl mesa-utils nickle cairo-5c xorg-docs-core xfonts-cyrillic
Recommended packages:
  libgpm2
The following NEW packages will be installed:
  acl adwaita-icon-theme at-spi2-core autoconf automake autotools-dev binutils binutils-common
  binutils-x86-64-linux-gnu blt build-essential bzip2-doc ca-certificates-java casacore-data casacore-data-igrf
  casacore-data-jpl-de200 casacore-data-jpl-de405 casacore-data-lines casacore-data-observatories
  casacore-data-sources casacore-data-tai-utc cpp cpp-8 cython3 dbus-user-session dconf-gsettings-backend
  dconf-service default-jre default-jre-headless dh-python dpkg-dev fakeroot fontconfig fontconfig-config
  fonts-dejavu-core fonts-dejavu-extra g++ g++-8 gcc gcc-8 gdb gfortran gfortran-8 glib-networking
  glib-networking-common glib-networking-services gsettings-desktop-schemas gtk-update-icon-cache hicolor-icon-theme
  i2c-tools ibverbs-providers icu-devtools iraf iraf-noao java-common javascript-common libaec0 libalgorithm-diff-perl
  libalgorithm-diff-xs-perl libalgorithm-merge-perl libapr1 libaprutil1 libasan5 libasound2 libasound2-data
  libasyncns0 libatk-bridge2.0-0 libatk-wrapper-java libatk-wrapper-java-jni libatk1.0-0 libatk1.0-data libatomic1
  libatspi2.0-0 libauthen-sasl-perl libbabeltrace1 libbinutils libblas-dev libblas3 libbluetooth3
  libboost-python1.67.0 libbz2-dev libc-ares2 libc-dev-bin libc6-dbg libc6-dev libcaf-openmpi-3 libcairo-gobject2
  libcairo2 libcasa-casa3 libcasa-coordinates3 libcasa-fits3 libcasa-images3 libcasa-lattices3 libcasa-measures3
  libcasa-mirlib3 libcasa-ms3 libcasa-python3-3 libcasa-scimath-f3 libcasa-scimath3 libcasa-tables3 libcc1-0
  libcfitsio7 libcminpack1 libcoarrays-dev libcoarrays-openmpi-dev libcolord2 libcos4-2 libcroco3 libcups2
  libdata-dump-perl libdatrie1 libdconf1 libdpkg-perl libdrm-amdgpu1 libdrm-common libdrm-intel1 libdrm-nouveau2
  libdrm-radeon1 libdrm2 libdw1 libencode-locale-perl libepoxy0 liberfa1 libevent-2.1-6 libevent-core-2.1-6
  libevent-pthreads-2.1-6 libexif12 libexpat1-dev libfabric1 libfakeroot libfftw3-double3 libfftw3-single3
  libfile-basedir-perl libfile-desktopentry-perl libfile-fcntllock-perl libfile-listing-perl libfile-mimeinfo-perl
  libflac8 libfont-afm-perl libfontconfig1 libfontenc1 libfribidi0 libftdi1-2 libfuntools1 libgail-common libgail18
  libgcc-8-dev libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgfortran-8-dev libgfortran5
  libgif7 libgl1 libgl1-mesa-dri libglapi-mesa libglvnd0 libglx-mesa0 libglx0 libgphoto2-6 libgphoto2-l10n
  libgphoto2-port12 libgraphite2-3 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2.0-0 libgtk2.0-bin libgtk2.0-common
  libharfbuzz0b libhdf5-openmpi-103 libhidapi-hidraw0 libhidapi-libusb0 libhtml-form-perl libhtml-format-perl
  libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl
  libhttp-message-perl libhttp-negotiate-perl libhwloc-dev libhwloc-plugins libhwloc5 libi2c0 libibverbs-dev
  libibverbs1 libice6 libicu-dev libieee1284-3 libimagequant0 libio-html-perl libio-socket-ssl-perl libio-stringy-perl
  libipc-system-simple-perl libipt2 libisl19 libitm1 libjack-jackd2-0 libjansson4 libjbig0 libjpeg-dev libjpeg62-turbo
  libjpeg62-turbo-dev libjs-jquery libjs-jquery-datatables libjson-glib-1.0-0 libjson-glib-1.0-common
  libkyotocabinet16v5 liblapack-dev liblapack3 liblcms2-2 libldb1 libllvm7 liblog4tango5v5 liblsan0 libltdl-dev
  libltdl7 liblwp-mediatypes-perl liblwp-protocol-https-perl liblzma-dev liblzo2-2 libmad0 libmailtools-perl
  libmariadb3 libmpc3 libmpfr6 libmpx2 libncurses-dev libncurses5-dev libnet-dbus-perl libnet-http-perl
  libnet-smtp-ssl-perl libnl-3-200 libnl-3-dev libnl-route-3-200 libnl-route-3-dev libnorm1 libnspr4 libnss3
  libnuma-dev libnuma1 libodbc1 libogg0 libomniorb4-2 libomnithread4 libopenal-data libopenal1 libopenmpi-dev
  libopenmpi3 libopus0 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpaper-utils libpaper1 libpcap0.8
  libpciaccess0 libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5 libpcsclite1 libpgm-5.2-0 libpixman-1-0 libpmix2
  libpng-dev libpng-tools libportaudio2 libprelude23 libpreludecpp8 libproxy1v5 libpsm-infinipath1 libpsm2-2 libpulse0
  libpython3-dbg libpython3-dev libpython3.7 libpython3.7-dbg libpython3.7-dev libqrencode4 libquadmath0 librdmacm1
  libreadline-dev librest-0.7-0 librsvg2-2 librsvg2-common libsamplerate0 libsane libsane-common libsensors-config
  libsensors5 libserf-1-1 libsfml-audio2.5 libsfml-graphics2.5 libsfml-network2.5 libsfml-system2.5 libsfml-window2.5
  libsigsegv2 libsiloh5-0 libsm6 libsmbclient libsndfile1 libsndio7.0 libsnmp-base libsnmp30 libsodium23
  libsoup-gnome2.4-1 libsoup2.4-1 libstarlink-ast-err0 libstarlink-ast0 libstarlink-pal0 libstdc++-8-dev libsvn1
  libsz2 libtalloc2 libtango9 libtcl8.6 libtdb1 libtevent0 libthai-data libthai0 libtie-ixhash-perl libtiff5
  libtimedate-perl libtk-img libtk8.6 libtool libtry-tiny-perl libtsan0 libubsan1 liburi-perl libutempter0
  libutf8proc2 libvorbis0a libvorbisenc2 libvorbisfile3 libwayland-client0 libwayland-cursor0 libwayland-egl1
  libwbclient0 libwcs6 libwcstools1 libwebp6 libwebpdemux2 libwebpmux3 libwww-perl libwww-robotrules-perl
  libx11-protocol-perl libx11-xcb1 libx86-1 libxaw7 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0
  libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxft2
  libxi6 libxinerama1 libxkbcommon0 libxml-parser-perl libxml-twig-perl libxml-xpathengine-perl libxmu6 libxpa1
  libxpm4 libxrandr2 libxrender1 libxshmfence1 libxslt1.1 libxss1 libxt6 libxtst6 libxv1 libxxf86dga1 libxxf86vm1
  libzmq5 linux-libc-dev m4 make manpages-dev mariadb-common mysql-common ocl-icd-libopencl1 openjdk-11-jre
  openjdk-11-jre-headless openmpi-bin openmpi-common patch pkg-config prelude-utils python-talloc python3-astropy
  python3-atomicwrites python3-attr python3-blist python3-bluez python3-btrees python3-cairo python3-cairo-dbg
  python3-casacore python3-crypto python3-crypto-dbg python3-cups python3-dbg python3-decorator python3-deltarpm
  python3-dev python3-ftdi1 python3-gevent python3-gevent-dbg python3-greenlet python3-greenlet-dbg python3-grpcio
  python3-gssapi python3-hid python3-http-parser python3-icu python3-icu-dbg python3-indexed-gzip python3-ipython
  python3-ipython-genutils python3-jinja2 python3-jpy python3-jpype python3-kdtree python3-kdtree-dbg
  python3-kyotocabinet python3-ldap python3-ldap-dbg python3-markupsafe python3-more-itertools python3-newt
  python3-nss python3-numpy python3-olefile python3-persistent python3-pexpect python3-pickleshare python3-pil
  python3-pluggy python3-ply python3-prelude python3-prompt-toolkit python3-psutil python3-ptyprocess python3-py
  python3-pyalsa python3-pyasn1 python3-pyasn1-modules python3-pyaudio python3-pygments python3-pyisomd5sum
  python3-pymad python3-pymad-dbg python3-pyodbc python3-pypcap python3-pyraf python3-pytest python3-pytest-arraydiff
  python3-pytest-astropy python3-pytest-doctestplus python3-pytest-openfiles python3-pytest-remotedata python3-pyxattr
  python3-pyxattr-dbg python3-qrencode python3-radix python3-rpy2 python3-sane python3-scipy python3-selinux
  python3-sendfile python3-sendfile-dbg python3-sfml python3-silo python3-simplegeneric python3-smbc python3-smbus
  python3-stsci.tools python3-subvertpy python3-tango python3-tk python3-traitlets python3-urwid python3-wcwidth
  python3-wheezy.template python3-yenc python3-zodbpickle python3.7-dbg python3.7-dev r-base-core r-base-dev
  r-cran-boot r-cran-class r-cran-cluster r-cran-codetools r-cran-foreign r-cran-kernsmooth r-cran-lattice r-cran-mass
  r-cran-matrix r-cran-mgcv r-cran-nlme r-cran-nnet r-cran-rpart r-cran-spatial r-cran-survival r-doc-html
  r-recommended read-edid samba-libs sane-utils saods9 saods9-doc tango-common tcl tcl-signal tcl-tls tcl-xpa tcl8.6
  tcliis tcllib tclxml tk tk-html1 tk-mpeg tk-table tk8.6 tk8.6-blt2.5 tkblt tkcon tksao unzip update-inetd x11-common
  x11-utils x11-xserver-utils xbitmaps xdg-utils xterm zip zlib1g-dev
The following packages will be upgraded:
  bzip2 libbz2-1.0 libexpat1 libicu63 libncurses6 libncursesw6 libpython3.7-minimal libpython3.7-stdlib libtinfo6
  python3.7 python3.7-minimal
11 upgraded, 554 newly installed, 0 to remove and 74 not upgraded.
Need to get 477 MB of archives.
After this operation, 1,676 MB of additional disk space will be used.
Do you want to continue? [Y/n]

To only install python 3.6 and its standard library, I would need 1600 MB. I find this extremely huge, especially since my system is 1.3 GB heavy and already has python 2.7 and 3.7 provided, and since the Windows .exe installer is only 25 MB.

I could install this as-is, but as I said, I try to take care about the storage space - plus, I'd want to do things in a clean way, and I guess a lot of packages in there are not really needed.

I guess apt probably provides me packages that I do not really need in a python installation: if it is the case, what do I need to do to remove them? And if I cannot: is there a reason why installing python3.6 takes so much storage on a Debian?

Thank you!

  • 1
    "Note, selecting '...' for regex 'python3.6'. There is no python3.6 package, so it's doing a regex match across package names. The python3 package is probably already 3.6. – muru May 14 at 13:40
3

This is apt being overly helpful: if apt install fails to match the specified package, and the package contains ., ?, or *, then it is interpreted as a regular expression, and any matching package is selected for installation. In your case, python3.6 doesn’t exist, so apt proceeds to try to install a huge amount of related packages.

There’s no general way to install a specific version of Python using apt; you can only install one of the available versions (for Python 3 in Debian 10, that’s Python 3.7).

To work with specific versions of Python, you should use virtual environments instead of trying to install a system-wide Python package. See this answer for details.

(On Debian 10, a default Python installation on top of the base system occupies 36.3MB of disk space.)

| improve this answer | |
  • So you mean we can install entire Python interpreters inside a virtualenv? I would be curious if you provided me a helpful link, as virtualenvs were always a mystery to use for me. – Ailothaen May 14 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.