0

Our VMs run on VMWare. I am not certain the version, but I want to say it is ESX 6 (or vSphere 6). The guests I support and administer are all CentOS 7

Today, I wen through and extended both a physical and logical volume to use recently added disk space. The allocation and resizing went fine with no issues. I then restarted the VM to ensure the changes took and no errors occurred.

This is where I have my issue. After the reboot I can no longer ssh into the VM. I have access to the VMs through the vSphere client. The status of the VM looked good. It was in a running state, I could see all IP addresses being used (we run several docker containers so a number of IP addresses display), there was CPU and memory usage.

I opened a remote console and tried logging in with two different admin users. Neither would work, I was return to the login prompt after what seemed like 30 seconds. I've restarted the VM trying different options, such as using the rescue kernel, going into grub and settings such as root, linux kernel, etc. Each time the VM starts and loads to the login prompt and that's it.

I would assume, if there was an error I would see that and be taken to an emergency/crash shell, but no such thing. From all appearances, the VM seems to have started correctly.

On our vCenter, I only have minimal rights. So my questions are:

  1. Is there any way to bypass the login, from the console only, to be able to review the boot records? I assume no as that would be a huge security risk.
  2. Is there anyway to see if anything has been reported from the guest to the host? Again, I assume there is, and I do not have the access to view the output.
  3. Is there any way to get the boot records from the guest as there is no way to log into it? I assume there is not
  4. I have an ISO I have mounted, but I cannot change the setting to force a BIOS Setup, so Is there a way, using the grub command line, to fake the VM into not having an installed OS? I want to do this in an attempt to repair the install, boot record, etc.
4
  • rootusers.com/how-to-reset-root-user-password-in-centos-rhel-7 ; google also hot add linux disks. May 14, 2020 at 1:41
  • @RuiFRibeiro, Changing the root password did nothing to resolve the issue. As stated above, the system boots and comes up the the standard console login prompt. After enter credentials, the system pauses and returns to the login prompt. I need to know why I am not able to login, why none of the standard processes appear to have started, specifically ssh. May 14, 2020 at 15:31
  • Check if your /var is full. May 14, 2020 at 16:04
  • My /var partition is 186 GB. That was the PV and LV I extended May 14, 2020 at 16:08

1 Answer 1

0

I was able to figure out how to get into a recovery prompt and determine the issue.

I restarted the VM and at the grub menu I simply pressed "c" to enter a console. I then attached an ISO to the virtual CDROM and exited the grub command-line. That allowed for the the VM to boot from the ISO, allowing me to enter into recovery mode.

I was then able to review the message log and I saw where I resized the the fs and did pv and lv checks followed by the reboot. The log showed system boot and always normal, but once it reached a running state there were all kinds of strange items listed, such as:

  • IPTABLE drops
  • Docker not being able to start, pull, or other wise work with containers
  • network interfaces entering into disabled mode
  • rsyslog exceptions

and the list goes on. I also realized something else. I saw firehol starting and I remembered I had installed it, but never finished configuring it, and I thought I uninstalled it. So I went through and removed firefol and ipranges via yum. I also cleaned out /var/lib/docker of all images, containers, and volumes. I then restarted the VM and I was able to ping the ip address, I could not ssh into the VM and all seems to be working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .