1

Behaviour description

In Manjaro (20, XFCE), my mouse wheel switches between workspaces when I scroll up/down outside a window. I can be 'active' within a window (typing, eg) and move to select or to scroll in another window, but if the cursor is outside the boundaries of an active application (browser, word processor, terminal, etc) and I scroll a single notch up/down, it switches to the next workspace in sequence.

Question

Can anybody advise on how to stop/control this behaviour?

Research and things I've tried

  1. Within the Workspace Switcher properties, under behaviour, I unticked "Switch workspaces using the mouse wheel". This worked briefly but was shortlived: presumably a package update somewhere has overridden this. Toggling it on and off makes no difference now.

  2. This question is the closest I've found to a similar issue, but I'm not in a VirtualBox and don't have i3 running. I've not had any fortune in using xev other than establishing that my upward scroll is indeed button 4 and downward is button 5.

Does anybody have any recommendations on where to look for control over this? Thanks in advance.

2 Answers 2

1

I'm able to disable this setting in "Window Manager Tweaks" (xfwm4-tweaks-settings) in the Workspaces tab. I'm running Debian.

Window Manager Tweaks

0

In Manjaro KDE desktop, this behavior can be disabled with: right-click on the desktop > Configure Desktop and Wallpaper > Mouse Actions

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .