0

I am searching for this solution for quite a bit.

I do not have access to ~/.Xresources; probably it's disabled by the administrator. Hence I need to set the facesize from the terminal.

xterm -xrm "XTerm.VT100.faceSize 24"

It opens an xterm but with default faceSize 14. How can I change it from the commandline?

I know it's possible to Ctrl+rightclick and then select on of the drop-down options. But I am looking for either:

  1. a permanent solution (e.g. a file in home directory)
  2. or setting it from terminal when I call xterm (so that I can put into my aliases)

Thanks.

6
  • 1
    How did you conclude you don't have access to .Xresources? Remember it is a dot file and thus many file managers won't display it unless told so. And yes, you can use an alias with that. How to create one? – Quasímodo May 12 '20 at 11:01
  • You're also missing a colon: xterm -xrm "XTerm.VT100.faceSize: 24" – Quasímodo May 12 '20 at 11:03
  • @Quasímodo by doing ls ~/.x (tab-key) , ~/.X (tab-key). The only hit was .xsession-errors. 'colon' or 'no colon' this doesn't work. Yes, I can create an alias once I get to the right option. I would appreciate an answer. – tt_pre May 12 '20 at 11:16
  • 2
    Just because a ~/.Xresources file doesn't exist in your account, it doesn't mean it's been disabled by your administrator. Just create the file yourself with a text editor of your choice. – steeldriver May 12 '20 at 12:08
  • Ok, I created a ~/.Xresources file with a single line in it: XTerm.VT100.faceSize: 24 . Executed xrdb -load ~/.Xresources --> no impact. xrdb -merge ~/.Xresources --> also no impact. What am I doing wrong? – tt_pre May 12 '20 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.