0

I've pulled the source package of luajit with apt source luajit from Debian sid. As the package was unpacked by the same command, I saw the next message:

dpkg-source: info: applying 0002-Enable-debugging-symbols-in-the-build.patch

Although I did not ask for any patches to be applied automatically, I'd like to review what this patch did, and possibly revert it.

Within the unpacked directory of the source package, the command what-patch replied with quilt. Since doing it the first time, I've installed quilt (v0.66) from sid, then went to cd ./debian/patches and attempted to do:

quilt diff -P ./0002-Enable-debugging-symbols-in-the-build.patch

to have a clearer picture of what this patch supposed to do in the upstream code; however, quilt strangely replied:

Patch ./0002-Enable-debugging-symbols-in-the-build.patch is not in series

So I reviewed the ./series file with cat ./series and clearly saw the line:

0002-Enable-debugging-symbols-in-the-build.patch

mentioned in there along 7 other patches (1 before, and 6 after). So, what is missing? I went to man quilt and read the diff command says:

Produces a diff of the specified file(s) in the topmost or specified patch. If no files are specified, all files that are modified are included.

And, the -P switch does:

Create a diff for the specified patch. (Defaults to the topmost patch.)

It seems I can't figure out what's wrong with quilt because I've never done this before and the manpages + the Debian wiki kinda moved past that in their tutorials.

2

It turned out to be a trivial confusion with quilt diff's -P and the [file ...] at the end of the quilt diff command. Apparently the ./ prefix before the filename of the patch breaks quilt's resolution within ./series when using -P, or rather that -P doesn't expect ./ at all. Therefore the correct syntax for:

quilt diff -P ./0002-Enable-debugging-symbols-in-the-build.patch

Is:

quilt diff -P 0002-Enable-debugging-symbols-in-the-build.patch

Now it shows the diff as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.