8

I was using 19. Ubuntu recommended an update. I clicked all the buttons and let it do its thing.

After the update restarted the computer, I tried using the mouse. Nothing. I tried the keyboard. Nothing.

A couple manual restarts later, I get the mouse to work for half a second before it goes dead. I have no idea how to fix this type of problem. I suppose I could try a fresh install in the BIOS, but is there a possibly less extreme method? I spent a lot of time setting my environment up and I don't want to lose it.

6
  • Note: normally I would ssh into the machine, but that's not currently active after the restart.
    – Gavin Nop
    May 10 '20 at 10:42
  • live cd & chroot? May 10 '20 at 10:50
  • Had the same problem. Managed to get them both working bt spamming Ctrl+Alt+F3 while booting, and after getting to a black screen using once Ctrl+Alt+F1. I have no idea what I have done, and it doesn't actually solve the problem (rebooting the computer the problem persisted, and using the trick again solved it again). If anyone knows what I have done, please tell me XD
    – DeadlosZ
    May 10 '20 at 12:01
  • ok, after doing that and then disabling auto-login I think I solve the problem for now. This is sort of a solution, but I have no idea why it works or if it damages other stuff...
    – DeadlosZ
    May 10 '20 at 12:34
  • Thanks, I'll try that. The auto-login has caused me problems before.
    – Gavin Nop
    May 11 '20 at 15:01
0

I figured this out - for me it had to do with auto-login and GDM.

I had to ssh in with X11 forwarding, launch the gnome-settings app and disable auto-login.

Then I went and apt removed with purge gdm and then re-installed it as well as the Ubuntu default login manager (forgot that it is called). It asked which login manager I wanted to use and I chose one.

I rebooted and it worked.

Sorry i don't have all the specific details here, but hopefully this helps.

0

Same problem for me, but with a fresh install. Everything was fine until I installed the nvidia proprietary driver. Then, no keyboard nor mouse anymore.

I found a trick that resolve my issue. I added "GRUB_GFXPAYLOAD_LINUX=text" to /etc/default/grub, ran sudo update-grub2 and then rebooted. gnome-session-flashback, autologin with nvidia driver and no issue anymore.

0
0

I have the same problem. After upgrade to 20.04, mouse and keyboard are not recognised by the GUI. Pressing Ctrl+Alt+Del reboots the machine immediately without going through the normal shutdown questionnaire ("are you sure you want to restart?" thing). I have discovered that if I boot into recovery mode and then opt to continue to a normal boot, it all works as expected.

Booting straight into the GUI, however, does not work.

1
  • Same here. Everything worked fine in 19.04, but the upgrade to 20.04 breaks the mouse and keyboard. Has anyone figured this out? One suggestion that I found that seemed to work is to change from Gnome to a different window manager like KDE or LXDE. I tried that and it seemed to work, but there were other issues. A clean install of 20.04 brought the original problem back. SERIOUSLY thinking of ditching Ubuntu in favour of Manjaro or something
    – Tony Kerr
    Aug 7 '20 at 1:32
0

Same problem here on a zbook, after upgrading to Ubuntu 20.04 neither mouse nor keyboard were working anymore. I could solve the mouse problem. I had to:

  • Install cygwin, xserver-org, xinit and ssh on my windows machine
  • In a cygwin terminal, start the X server: startxwin
  • Then ssh -Y into the Ubuntu Linux machine
  • To be able to start the GNome settings app I had to run dconf reset -f /org/gnome/control-center/ first.
  • Then started the gnome-control-center.
  • There auto-login was off for my user. I wanted to turn it on, but the app said that it could not unlock these settings.
  • So I had to edit the policy file: sudo vi /usr/share/polkit-1/actions/org.gnome.controlcenter.user-accounts.policy
  • There I set allow_any to yes.
  • Then I restarted the gnome-control-center and activated auto-login for my user.
  • Finally: reboot

Now it auto-logs-in to my user account, the mouse is working, but the keyboard is still not working. Hopefully I find a solution for that too.
Maybe the detailed list of steps helps somebody else with the same problem.

-1

half of my keyboard was not working. I tried this. But the settings on my laptop were fine. Anyway I did the wrong settings. Enabled: Settings>Universal Access>Typing>Typing Assist(Access X) I enabled all the settings in that dialogue box.

closed the settings. The keyboard stopped working altogether.

Disabled: Settings>Universal Access>Typing>Typing Assist(Access X)

Now the keyboard is working :D

2
  • 1
    This seems to be unrelated to the question. The user's mouse isn't working.
    – Kusalananda
    Sep 1 '20 at 13:33
  • Unrelated since there is no mouse or keyboard Sep 25 '21 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.