2

I already had Windows 10 installed on my PC. Recently I installed Ubuntu 18.04 alongside Windows. After completing the installation the PC is unable to boot; I get this message at startup:

System BootOrder not found. Initializing defaults.
Creating boot entry "Boot000B" with label "ubuntu" for file "\EFI\ubuntu\shimx64.efi"

Reset System

I get the same message every time I boot.

It is important to note that I installed Windows in Legacy BIOS mode where as the Ubuntu was installed using EFI. Now, there are separate BIOS modes for each system and I am unable to boot Windows even from "Boot from File" option in the "Boot Order menu". When I boot from the legacy boot entry of Windows in boot order it says boot device not found please install operating system. I am using HP Elitebook 840 G2.

This is how the partitions on my disk are configured:

Device     Type     Mount point
/dev/sda1  ntfs
/dev/sda2  ntfs
/dev/sda3  efi
/dev/sda5  swap
/dev/sda6  ext4     /
3

Not sure if this is exactly your issue, but I ran into the same error when I installed Mint for dual-booting with Windows. My HP laptop had the option in

  • UEFI > Boot options > Advanced

to add a Customized Boot.

It allows you to enter a path and that's where I added \EFI\ubuntu\shimx64.efi.

Then I changed the boot order to have Customized Boot on top and it booted into GRUB magically. If you can do something similar, this may just solve the issue for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.