0

I've got a 1TB external drive in NTFS encrypted with Bitlocker. I wanted to open it in Linux (Mint), so I quickly followed a tutorial like a real noob, not understanding how it worked, just pasting lines in the terminal.

  1. I plugged my USB drive to the computer

  2. I installed Dislocker

  3. sudo mkdir /media/bitlocker sudo mkdir /media/mount

  4. sudo fdisk -l

  5. sudo dislocker -r -V /dev/thedrive -uMyPassword -- /media/bitlocker

And after that it told me something like batch invalid. I don't remember actually.

The thing is, when I plugged my drive in another computer with Windows, it directly prompted me to format my drive. And so it did on the other computer with Windows I tried.

I'm stupid I wanted to go too fast as a beginner. And I have a lot of important data on that drive.

I did some researches on solutions. I found some things about repairing the MBR with TestDisk (that I installed in case). And other things. But I couldn't find a solution that was exactly about my problem (with dislocker I guess) so I prefer to ask on a forum with people who could understand it before doing anything.

My goal is to repair my drive, and be able to fully decrypt it on a Windows computer (what I should have done first)

Can someone explain me why I screwed my drive, and what I can make to repair it?

Thank you, a lot. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.