Synaptic and the likes are giving me this error: You have 1 broken package on your system.

I have tried to use the fix broken packages option but Synaptic simply crashes. It seems that Firefox 17.0.1 is the package causing all the issues.

So I tried to use sudo apt-get -f install firefox and received these errors

$ sudo apt-get -f install firefox
Reading package lists ... Done
Building dependency ratio
Reading state information ... Done
Suggested packages: latex-xft-fonts
The following packages will be upgraded: firefox
1 upgraded, 0 newly installed, 0 to remove and 16 not upgraded.
1 packages not fully installed or removed.
Must obtain 0 B/22.4 MB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 161323 files and directories currently installed.)
Preparing to replace firefox 17.0 + build2-0ubuntu0.11.10.1 (using ... /   firefox_17.0.1 + build1-0ubuntu0.11.10.1_amd64.deb) ...
Unpacking replacement firefox ...
dpkg: error processing / var/cache/apt/archives/firefox_17.0.1 + build1-0ubuntu0.11.10.1_amd64.deb (- unpack):
trying to overwrite '/ usr / lib / firefox / extensions "that are also present in the package mint-search-addon 2011.08.15
Please restart all running instances of firefox, or you will experience problems.
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding / usr / share / applications / bamf.index ...
Processing triggers for gnome-menus ...
Errors occurred in the treatment of:
 / Var/cache/apt/archives/firefox_17.0.1 + build1-0ubuntu0.11.10.1_amd64.deb
E: Sub-process / usr / bin / dpkg returned an error code (1)

Next I tried using

sudo apt-get install && sudo-apt get update reinstall firefox
sudo apt-get remove --purge firefox
sudo apt-get update

Unfortunately they were all to no avail. I also tried reinstalling synaptic but that too failed. What is wrong?

  • have you tried sudo apt-get update && sudo apt-get upgrade && sudo apt-get reinstall firefox Dec 15 '12 at 12:55
  • 1
    Where did you get this version of Firefox from? The Firefox package you're trying to install is incompatible with the Mint addon package. You'll have to either stick with Mint's Firefox package or uninstall the Mint addon package. Dec 15 '12 at 22:37
  • This version of firefox was just a regular update through the mint updater. Dec 16 '12 at 6:40

It seems your Software Index is broken.

Try sudo apt-get install -f and sudo apt-get autoremove

Clean and Update apt there-after.


To solve broken package problem on Ubuntu, you need to purge it which is related to PPA or software source. There are several way to solve this problem. Please see this guide:

1. Cleaning using this command.

% sudo apt-get clean && sudo apt-get update

2. If you fail using the first command, try to use this one:

% dpkg --configure -a

3. Try this command if you failed to remove broken package using the second command:

% apt-get -f install

The last command will help you to remove all broken package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.