I've installed Samba on my Arch Linux, and I wanted to share files with Windows 7 on other PC via local network. I want it to work both ways, i.e. Windows can read and write freely without any authentication into designated public share on Linux machine, and Linux can do the same thing with Windows machine. I have configured Samba and created appropriate share, but it's not working, i.e. neither PC can see the other. Windows is in MSHOME workgroup, and Linux is in LINUX workgroup.

I made smb.conf from smb.conf.default, the only changes were setting computer name and workgroup, and adding the following at the end:

    path = /media/public
    public = yes
    read only = no

The only configuration I did on Windows was adding registry entries to HKLM/SYSTEM/CurrentControlSet/services/LanmanWorkstation/Parameters: DNSNameResolutionRequired set to 0 and DomainCompatibilityMode set to 1, as was said to do on Samba Wiki.

What should I do to make things work?

1 Answer 1


Changed networking options on Windows to "Use user accounts and passwords to connect to other computers", set registry key HKLM\SYSTEM\CurrentControlSet\Control\Lsa\LmCompatibilityLevel to DWORD:2, changed security level in smb.conf to "share", and now it works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .