0

I have this problem with Docker containers on one of my servers running OMV 5 on Debian 10.

Temporary failure resolving

About this setup. I have recently installed OMV 5 on two x86 and one ARM server. The problem appears just on one of server, while inside the host os dns seems to work fine, I can install and upgrade packages, in docker containers it simply does not work. I tried to followw several guides, nothing helped so far. Also restored the image and reinstalled docker several time. Also the servers have identical OS images just with a few configuration changes related to disks. I've tried this guide https://development.robinwinslow.uk/2016/06/23/fix-docker-networking-dns/ and this https://www.dedoimedo.com/computers/docker-container-no-network.html On all servers I get this

root@mars:~# docker run busybox nslookup google.com
Server:         192.168.1.1
Address:        192.168.1.1:53

Non-authoritative answer:
Name:   google.com
Address: 172.217.20.174

*** Can't find google.com: No answer

On two servers it works (arm and x86):

root@venus:~# docker run -t -i ubuntu /bin/bash
root@9e4dce3d6ad9:/# apt update
Get:1 http://archive.ubuntu.com/ubuntu focal InRelease [265 kB]
Get:2 http://security.ubuntu.com/ubuntu focal-security InRelease [107 kB]
Get:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease [107 kB]
Get:4 http://archive.ubuntu.com/ubuntu focal-backports InRelease [98.3 kB]
Get:5 http://security.ubuntu.com/ubuntu focal-security/universe amd64 Packages [8273 B]
Get:6 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages [60.9 kB]
Get:7 http://archive.ubuntu.com/ubuntu focal/multiverse amd64 Packages [177 kB]
Get:8 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 Packages [4673 B]
Get:9 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages [11.3 MB] 
Get:10 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages [1275 kB]                                                                                                                                                                                                                   
Get:11 http://archive.ubuntu.com/ubuntu focal/restricted amd64 Packages [33.4 kB]                                                                                                                                                                                                             
Get:12 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [31.6 kB]                                                                                                                                                                                                       
Get:13 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages [4673 B]                                                                                                                                                                                                      
Get:14 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [104 kB]                                                                                                                                                                                                            
Get:15 http://archive.ubuntu.com/ubuntu focal-backports/universe amd64 Packages [2903 B]                                                                                                                                                                                                      
Fetched 13.6 MB in 10s (1389 kB/s)                                                                                                                                                                                                                                                            
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
root@9e4dce3d6ad9:/# 

but on the 3rd(x86) I get this

root@mars:~# docker run -t -i ubuntu /bin/bash
root@173885bb1bfa:/# apt update
Err:1 http://archive.ubuntu.com/ubuntu focal InRelease
  Temporary failure resolving 'archive.ubuntu.com'
Err:2 http://security.ubuntu.com/ubuntu focal-security InRelease
  Temporary failure resolving 'security.ubuntu.com'
Err:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease
  Temporary failure resolving 'archive.ubuntu.com'
Err:4 http://archive.ubuntu.com/ubuntu focal-backports InRelease
  Temporary failure resolving 'archive.ubuntu.com'
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/focal/InRelease  Temporary failure resolving 'archive.ubuntu.com'
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/focal-updates/InRelease  Temporary failure resolving 'archive.ubuntu.com'
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/focal-backports/InRelease  Temporary failure resolving 'archive.ubuntu.com'
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/focal-security/InRelease  Temporary failure resolving 'security.ubuntu.com'
W: Some index files failed to download. They have been ignored, or old ones used instead.

My router is running OpenWrt 19.07, I also reboot it amd delete the dhcp leases. Which resolved the problem that the installed could not auto configure networks. I also found and started a container with X and VNC. In browsers DNS works fines, but not in apt. See image with working google

I also use henet tunnel brocker to get ipv6.

2
  • This looks like a network issue related to your docker environment. Could you please provide your docker-compose or the command used to spin up your container? – Christoph May 7 '20 at 15:58
  • It's in the original description. docker run -t -i ubuntu /bin/bash – Zero Cool May 7 '20 at 17:40
0

The issue is related to somekind of bug of how OMV installs docker and portainer be default received the IP of the gateway. Recreating docker storage w/o portainer solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.