0

after switching to modesetdriver for

    lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2
    00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor      Graphics Controller [8086:0166] (rev 09)
    Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:21f3]
    Kernel driver in use: i915

I had tearing when I looked Video. I was searching and read this could be a problem with composit. In may case it turns out it was the problem. So I tried to replace marco with openbox+compton. In mate-tweak openbox is not offered.

mate-tweak
Window Manager is: Unknown
Base layout: fedora
Current layout: fedora

mate-tweak

what tried so far. Swithing window-manager to openbox using update-alternatives

readlink -f /etc/alternatives/x-window-manager
/usr/bin/openbox

the next try was to use gsettings.

gsettings list-recursively org.mate.session.required-components
org.mate.session.required-components dock ''
org.mate.session.required-components windowmanager 'openbox'
org.mate.session.required-components panel 'cairo-dock' 
org.mate.session.required-components filemanager 'caja'

At least I ending up, with starting openbox and compton in autostart from mate-session. but I'm afraid, this is not a smart solution. How can I make it better?

Note creating an intel.conf is not an option. This push me right to vt; lightdm refuses to start.

0

short and painless. I moved the desktop files for openbox and and compton from

$HOME/.config/autostart/

to

/etc/xdg/autostart

and removed

apt purge mate-tweak
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.