In Debian Wheezy, I'm trying to install the vmware-view-client package from the Ubuntu Software Center (because the open client won't work for my situation), but dpkg can't handle it. Synaptic says I have libssl1.0.0 installed (1.0.1c-4, along with -dev and -doc), but I get the following error message:

$ dpkg -i vmware-view-client_1.6.0-0ubuntu0.13.04_i386.deb 
(Reading database ... 154107 files and directories currently installed.)
Preparing to replace vmware-view-client 1.6.0-0ubuntu0.13.04 (using vmware-view-client_1.6.0-0ubuntu0.13.04_i386.deb) ...
Unpacking replacement vmware-view-client ...
dpkg: dependency problems prevent configuration of vmware-view-client:
 vmware-view-client depends on libssl0.9.8 (>= 0.9.8m-1); however:
  Package libssl0.9.8 is not installed.

dpkg: error processing vmware-view-client (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:

Do I need to somehow get an earlier version of libssl (if so, how?) or can I somehow convince dpkg to use my version of libssl anyways?

2 Answers 2


0.9.8 is the ABI version (aka soversion), so, yes, you need to install the older version. The 0.9.8 and 1.0 ABIs are not compatible.

I'd suggest installing libssl0.9.8 in the normal manner, e.g., using the GUI or aptitude install libssl0.9.8. 0.9.8 is available in both 12.04 and 12.10 according to http://packages.ubuntu.com/

Then you should be able to install the vmware client.

  • Thanks! I got it from packages.debian.org/squeeze/i386/libssl0.9.8/download instead, but it worked! Dec 14, 2012 at 17:10
  • 2
    @NateParsons You should get it from your repository (Ubuntu in your case) to get security updates and not break upgrades. There's no reason for installing from other sources if your distribution provides it.
    – gertvdijk
    Dec 14, 2012 at 17:20
  • But I'm not running Ubuntu, I was just using its repository because VMWare doesn't provide any other way to download their debs. Dec 18, 2012 at 19:33
  • @NateParsons ah, if you're actually running Debian, you should have said so. We all assumed Ubuntu because you mentioned the Ubuntu Software Center. And that aptitude line should work on Debian, too.
    – derobert
    Dec 18, 2012 at 20:53
  • Whoops, I thought I had. Question updated. It's configured with aptitude now. Dec 18, 2012 at 21:18

If you really still need libssl0.9.8 for Debian, which was last in Debian 6 "Squeeze", you can find it in the archive at http://archive.debian.org/debian/pool/main/o/openssl/

The latest 0.9.8 version for i386 is http://archive.debian.org/debian/pool/main/o/openssl/libssl0.9.8_0.9.8o-4squeeze23_i386.deb

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .