1

I'm trying to setup a local offline repository of a few packages. For most packages this seems to be working, but for a few, there is a problem:

# cd /testrepo
# createrepo .
# ls -l
total 3360
-rw-r--r-- 1 root root  690704 May  6 15:30 aspell-0.60.6.1-21.el8.x86_64.rpm
-rw-r--r-- 1 root root  358739 May  6 14:01 libvirt-client-4.5.0-35.1.module_el8.1.0+258+1d2a1d58.x86_64.rpm
drwxr-xr-x 2 root root    4096 May  6 15:53 repodata
-rw-r--r-- 1 root root   78511 May  6 15:40 slf4j-1.7.25-4.module_el8.0.0+39+6a9b6e22.noarch.rpm
-rw-r--r-- 1 root root   49300 May  6 15:20 vim-filesystem-8.0.1763-13.el8.noarch.rpm
-rw-r--r-- 1 root root 1442748 May  6 13:59 words-3.0-28.el8.noarch.rpm
-rw-r--r-- 1 root root  802448 May  6 15:31 yelp-3.28.1-3.el8.x86_64.rpm
# zgrep packages repodata/*primary.xml.gz
<metadata xmlns="http://linux.duke.edu/metadata/common" xmlns:rpm="http://linux.duke.edu/metadata/rpm" packages="6">
...
# cat /etc/yum.repos.d/test.repo
[test]
name=Test
baseurl=file:///testrepo
gpgcheck=0
enabled=1
# yum clean all
# yum makecache
# yum repolist
... ... ... status
... ... ... 5

libvirt-client is missing for yum, also from /var/cache/dnf/packages.db, but it is there in the local repository.

And this test repository is the only one enabled. Why is the package missing? What did I do wrong? Or how can I search for what is going wrong? I saw this also, which seems similar: https://bugs.centos.org/view.php?id=17033 But no answer there.

Thank you.

8
  • Have you tried yum install libvirt-client? Also try rpm -qpl on that file to make sure it isn't broken. May 6, 2020 at 17:02
  • yum install libvirt-client gives back Error: Unable to find a match: libvirt-client. rpm -qpl lists the files to be installed, I can install the rpm directly without yum. But yum refuses to add it to its database somehow.
    – Thierry
    May 6, 2020 at 17:22
  • Have you tried rm -rf repodata; createrepo . ? There could be a stale manifest file in there. May 6, 2020 at 18:16
  • Yes, I have tried recreating the repository, and adding other packages later, and updating the repository. The other packages are listed by yum, only libvirt-client is (as far as I can tell) in the repository, but not listed by yum.
    – Thierry
    May 6, 2020 at 21:20
  • I wonder if you just found a bug in createrepo. Can you try with createrepo_c? It's a different implementation. May 6, 2020 at 21:40

1 Answer 1

2

I experience the same. I also think it is a bug. Logged it here: https://bugzilla.redhat.com/show_bug.cgi?id=2057253

The long of it is that some packages are provides in/with modules. So you need to consider that and add

module_hotfixes=1

to your repo config file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .