1

The context

This gif shows what happens when trying to opening scilab while using i3

enter image description here

This gif shows what happens when trying to opening scilab while using dwm

enter image description here

The problem

I'm currently using dwm because using tags is more suitable in more workflow than using workspaces with i3, so in order to use scilab I have to switch back to i3.

The question

Why does dwm behave like this while i3 not?

By understanding the context, I will be able to search through all the available dwm patches in order to discern whether a given one would be useful to solve this specific issue.

The current workaround

scilab-cli runs well in both dwm and i3, I can plot graphs and perform any operation, so for the moment I can use scilab-cli while using dwm.

Additional context

I wonder whether setting one of these environment variables might help

$ ./bin/scilab --randomtext 2>&1 | tail -n 6
  Several environment variables can be declared:
  SCIVERBOSE               Provides debugging information of the startup
  JAVA_HOME                Declares which Java Virtual Machine to use
  SCI_DISABLE_TK           Disables Tk (but not Tcl) features
  SCI_JAVA_ENABLE_HEADLESS Runs Java Headless VM (without GUI; Windows and Linux only)
  SCI_DISABLE_EXCEPTION_CATCHING Disable the catch by Scilab of exception (segfault, ...)
1

This is a common rendering issue with Java applications and non-reparenting window managers. There are 2 solutions:

  1. Use wmname to impersonate another window manager, e.g.
    $ wmname LG3D
    
  2. Set no-reparenting flag for JDK
    export _JAVA_AWT_WM_NONREPARENTING=1
    
| improve this answer | |
  • Thanks. The GUI now opens correctly. I didn't need to execute step 1, by the way. That is, I just needed to execute the following command _JAVA_AWT_WM_NONREPARENTING=1 scilab in an interactive shell. If you don't mind me asking, what other widely used programs behave like this? – gfe May 24 at 16:56
  • 1
    NetBeans, Eclipse, etc. Anything written in Java. – anlar May 24 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.