0

Running latest Xubuntu (20.04) and the this nice Lenovo Miix-320 that can be used as both laptop computer and as tablet, since they lower part (keyboard) is detachable.

Well, the screen likes to be upways (not sideways as usual monitor) when installed and run. I fixed this from settings after signin by simply setting it to rotate clockwise 90 degrees and now everything is ok, (well, kinda, the login screen is still sideways, but this is not a problem).

The problem is, that touchscreen "mouse" works as computer would still be in "upways mode"...kinda: When I move it left, if moves up. When I move it up, it moves to right. When I move it right, it moves down. When I move it down, it moves left. Now, as you see, moving it "left" would actually move it to "up" if it would be in "upways mode", so it kinda makes sense. Same thing happens when I click the touchscreen: A click in left hits the screen in top, click in the top hits the screen in right, click in the right hits the screen in bottom, and a click in the bottom hits the screen in left.

This problem occurs only with touchscreen. External mouse, trackpad mouse, etc. all work ok.

So, how can I fix this? How can I specify to touchscreen, that it should move 90 degrees to clockwise - in relation to entire screen - when I touch the screen? Making mouse move to 90 degrees would be a one big task, but how to heck make the entire screen register touches in this bizarre way?

Could the solution be to revert the "turn screen 90 degrees to clockwise" from the Xubuntu settings and somehow REALLY TURN the screen 90 degrees clockwise on ALL enviroments? How?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.