0

I am using Openbox 3.6.1 windowing with Arch 5.6.4, and NeoVim 0.4.3, with gnome-terminal 3.36.1. These are the most up to date versions.

I am currently sizing my gnome-terminal window using these lines within my NeoVim .vimrc file

set lines=36 columns=128

However this is not ideal becasue I frequently have different window layout needs.

What I want is for the window to open maximised, whatever my windowing layout.

On the gnome-terminal command line, the following command opens file rc.xml with nvim in the gnome-terminal, with maximised window as expected.

gnome-terminal --window --maximize -e "bash -c 'nvim /home/user/rc.xml'"

I dont usually open files with nvim this way though.

What I do is I call nvim in gnome terminal, using an Openbox key binding.

Here are 3 example key bindings I have tried within the rc.xml file ..

.. this keybinding opens the rc.xml file with nvim, but not with the maximised gnome-terminal window as needed ...

<keybind key="w-a-numbersign">
    <action name="Execute">
        <command>gnome-terminal --window --maximize -e "bash -c 'nvim /home/user/rc.xml'"</command>
    </action>
</keybind>

.. again .. this keybinding opens the rc.xml file with nvim, but not with the maximised gnome-terminal window as needed ...

<keybind key="w-a-numbersign">
                <action name="Execute"><command>gnome-terminal --window --maximize -e "/bin/bash -c '
                     nvim /home/user/rc.xml;
             exit;
             exec /bin/bash -i'"</command></action>
</keybind>

.. again .. this keybinding opens the rc.xml file with nvim, but not with the maximised gnome-terminal window as needed ...

<keybind key="w-a-numbersign">
      <action name="Execute"><command>/home/user/linux_config/script_vim/rc.xml.sh</command></action>
</keybind>

.. with the above script simply containing

#!/bin/bash
gnome-terminal --start-maximized -e \"bash -c 'nvim /home/user/rc.xml'\"

I am not aware of any parameter within my .vimrc file that is stopping the terminal window opening maximised.

Can anyone suggest how I can adjust my key binding to open this window maximised?

1 Answer 1

0

I found a gnome terminal syntax that allows the Openbox key binding to open the window maximised

<keybind key="w-a-numbersign"><action name="Execute"><command>bash -c '
    gnome-terminal --window --maximize -e "nvim /home/user/rc.xml";
'</command></action></keybind>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.