0

I installed the beep tool (from normal rep) on my ubuntu 18.04

After modprobe pcspkr everything was OK. But it has been heard from my very small beeper from the PC's box only. Is there a way to hear it from normal music loud speaker as like any mp3, youtube etc?

I note the echo -e '\007' bell command from my shell is heard from normal music loud speaker it is very good for me.

Using of -e option of beep didn't help.

1

Welcome to Unix & Linux StackExchange!

The beep tool is explicitly designed to use the beeper only.

The echo -e '\007' uses whatever bell effect your terminal emulator is configured to do: on the text-mode console, it typically uses the beeper. In a GUI desktop terminal window, the terminal emulator might have its own configurable beep sound, or it might use the desktop environment's default beep effect, which is usually configurable in the sound settings of the desktop environment.

Having said that, it is sometimes possible to redirect the beeper's sound into the speakers. In order to do that, you need an integrated sound chip (as most modern systems have), with a specific ability to reroute the beeper sound (which is included in some but not all sound chips). To enable that feature in Linux, you'll need to access the sound mixer functions of the actual sound card, instead of the simplified version that you'll get normally if your system includes the PulseAudio subsystem.

For example, if you use the alsamixer command with no options in a PulseAudio-enabled system, you may see the volume control of PulseAudio only. But if you explicitly specify the sound card to use with e.g. alsamixer -c 0 to specify the first sound card/chip of the system, you'll get the full audio mixer settings.

If the list of available sound channels includes "Beep", "Digital Beep" or something like that, it would be the PC beeper redirection channel. It might be just an on/off switch setting, or an adjustable level setting, or both. If you enable/unmute the channel, the beeper's signal should be redirected to the sound chip and output through the normal speakers.

Note: if your system has this feature and you decide to use it, check the volume level of the beep before you reboot the system. If you enable the redirection and set it to full volume, the standard beep at reboot time may come through the speakers and get amplified to unexpected loudness.

(Yes, this happened to me once. Apparently the sound chip is not always fully reset at reboot, at least not until the OS startup has proceeded to load the sound drivers again.)

4
  • Thank you for your detailed answer, I have beep column in alsamixer, but nothing effect if I changed the level, but e.g.: Master column worked well. I copied to gdrv 3 pictures from my alasmixer menu and my lshw output, if you could have more idea. drive.google.com/drive/folders/… May 25 '20 at 12:13
  • Did you unmute the beep channel first, by selecting the channel in alsamixer and pressing the M key so that the MM at the bottom of the channel level bar turns into OO? In your pictures, the beep channel is still muted (MM).
    – telcoM
    May 25 '20 at 12:27
  • Thanks, I've corrected it you can see on fourth jpg on the above link, but the e.g.: beep -f600 only sounds on the beeper not on the loudspeaker. May 27 '20 at 10:28
  • 1
    Then it probably means your motherboard’s manufacturer did not wire it in although the sound chip has the capability for it, unfortunately.
    – telcoM
    May 27 '20 at 10:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.