3

I have a WRT160NL router with OpenWrt Backfire (10.03.1, r29592), and there is a 3,5" WD Green 1,5TB HDD attached to it. In the recent time if I read the logs on it with "logread" I can see these messages:

Dec 12 17:07:16 OWRTROUTER user.err kernel: ath: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x00024020
Dec 12 17:07:16 OWRTROUTER user.err kernel: ath: Could not stop RX, we could be confusing the DMA engine when we start RX up
Dec 12 17:07:16 OWRTROUTER user.err kernel: ath: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x00024020
Dec 12 17:07:16 OWRTROUTER user.err kernel: ath: Could not stop RX, we could be confusing the DMA engine when we start RX up
Dec 12 17:07:17 OWRTROUTER user.err kernel: ath: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x00024020
Dec 12 17:07:17 OWRTROUTER user.err kernel: ath: Could not stop RX, we could be confusing the DMA engine when we start RX up

What are these messages? Are there a sign of a future problem? How to handle them?

1
  • ath would be your wireless card (or at least one of them). Probably a bug in the driver for it.
    – derobert
    Dec 13, 2012 at 21:52

1 Answer 1

0

ath would be your wireless card (or at least one of them). Probably a bug in the driver for it. – derobert Dec 13 '12 at 21:52

So the solution is to wait for updated firmware.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .