0

Summary:
I'm trying to connect from my laptop to my Desktop to transfer files using sftp username@localIP but it gives me connection timeout

Case:
Both machines are using Linux and connected to the same router:
machine 1: Desktop connected to internet using a USB tethering phone connected to the same router as the second machine
machine 2: Laptop connected to internet using wireless

IP for each device using hostname -I:
Desktop: 192.168.42.130
Laptop: 192.168.1.2

Issue:
I can connect from Desktop to Laptop but not vice versa. I used it a lot from Desktop->Laptop but each time i try to connect from Laptop->Desktop this happens:
(takes 2 minutes) (ssh: connect to host 192.168.42.130 port 22: Connection timed out connection closed)

1) tried to set GSPAuthentication to no
2) tried to set UseDNS to no
3) restarted the service

But to no avail

Update:
Below are results after scanning for the issue (@A.B suggested that the problem is due to NAT)

Note: Len short for Lenovo (i.e.laptop)
Note: There are only two Linux machines on the router
Note: I have no wire so i use on my desktop a cell phone to connect to internet (using USB tethering)

1) connecting from Laptop->Desktop:
omar@omar-Len:~/Desktop$ sftp omar@192.168.1.8 ssh: connect to host 192.168.1.8 port 22: Connection refused Connection closed

2) Checking Desktop Address (before connection):
omar@omar-LDesktop:~$ ip -brief address lo UNKNOWN 127.0.0.1/8 ::1/128 enp0s25 DOWN enp0s29f7u2 UNKNOWN 192.168.42.130/24 fe80::69ce:4a20:5a7e:433c/64

3) on the laptop to check open connections (before connecting the two machines):
omar@omar-Len:~/Desktop$ netstat -tn | egrep -w 22 omar@omar-Len:~/Desktop$

(connected the two machines from pc->laptop)

4) checking open connection:
(Desktop)
omar@omar-LDesktop:~$ netstat -tn | egrep -w 22 tcp 0 0 192.168.42.130:44644 192.168.1.2:22 ESTABLISHED

(Laptop)
omar@omar-Len:~/Desktop$ netstat -tn | egrep -w 22 tcp 0 0 192.168.1.2:22 192.168.1.8:44644 ESTABLISHED

(Desktop)
omar@omar-LDesktop:~$ ps -ef | grep [s]shd root 30538 1 0 19:07 ? 00:00:00 /usr/sbin/sshd -D

update 2: (I though of connecting the 2 machines through internet to avoid the NAT, so here is my trial)

I used sftp -vvv <publicIP>@<LocalIP>
to connect from Desktop->Laptop and it asked me for the password and when i entered it it returned back "Permission Denied" although it connects normal if i do not use the <publicIP>

Here is the debugging log from the Desktop: (note, i changed my <publicIP>)

sftp -vvv <publicIP>@omar-@omar-Len@192.168.1.2 OpenSSH_7.6p1 Ubuntu-4ubuntu0.3, OpenSSL 1.0.2n 7 Dec 2017 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug2: resolving "192.168.1.2" port 22 debug2: ssh_connect_direct: needpriv 0 debug1: Connecting to 192.168.1.2 [192.168.1.2] port 22. debug1: Connection established. debug1: key_load_public: No such file or directory debug1: identity file /home/omar/.ssh/id_rsa type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/omar/.ssh/id_rsa-cert type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/omar/.ssh/id_dsa type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/omar/.ssh/id_dsa-cert type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/omar/.ssh/id_ecdsa type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/omar/.ssh/id_ecdsa-cert type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/omar/.ssh/id_ed25519 type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/omar/.ssh/id_ed25519-cert type -1 debug1: Local version string SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.3 debug1: Remote protocol version 2.0, remote software version OpenSSH_7.6p1 Ubuntu-4ubuntu0.3 debug1: match: OpenSSH_7.6p1 Ubuntu-4ubuntu0.3 pat OpenSSH* compat 0x04000000 debug2: fd 3 setting O_NONBLOCK debug1: Authenticating to 192.168.1.2:22 as '<publicIP>@omar-@omar-Len' debug3: hostkeys_foreach: reading file "/home/omar/.ssh/known_hosts" debug3: record_hostkey: found key type ECDSA in file /home/omar/.ssh/known_hosts:1 debug3: load_hostkeys: loaded 1 keys from 192.168.1.2 debug3: order_hostkeyalgs: prefer hostkeyalgs: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521 debug3: send packet: type 20 debug1: SSH2_MSG_KEXINIT sent debug3: receive packet: type 20 debug1: SSH2_MSG_KEXINIT received debug2: local client KEXINIT proposal debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1,ext-info-c debug2: host key algorithms: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,ssh-ed25519,rsa-sha2-512,rsa-sha2-256,ssh-rsa debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1 debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1 debug2: compression ctos: none,zlib@openssh.com,zlib debug2: compression stoc: none,zlib@openssh.com,zlib debug2: languages ctos: debug2: languages stoc: debug2: first_kex_follows 0 debug2: reserved 0 debug2: peer server KEXINIT proposal debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1 debug2: host key algorithms: ssh-rsa,rsa-sha2-512,rsa-sha2-256,ecdsa-sha2-nistp256,ssh-ed25519 debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1 debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1 debug2: compression ctos: none,zlib@openssh.com debug2: compression stoc: none,zlib@openssh.com debug2: languages ctos: debug2: languages stoc: debug2: first_kex_follows 0 debug2: reserved 0 debug1: kex: algorithm: curve25519-sha256 debug1: kex: host key algorithm: ecdsa-sha2-nistp256 debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none debug3: send packet: type 30 debug1: expecting SSH2_MSG_KEX_ECDH_REPLY debug3: receive packet: type 31 debug1: Server host key: <hostKey> SHA256:<SHA256> debug3: hostkeys_foreach: reading file "/home/omar/.ssh/known_hosts" debug3: record_hostkey: found key type ECDSA in file /home/omar/.ssh/known_hosts:1 debug3: load_hostkeys: loaded 1 keys from 192.168.1.2 debug1: Host '192.168.1.2' is known and matches the ECDSA host key. debug1: Found key in /home/omar/.ssh/known_hosts:1 debug3: send packet: type 21 debug2: set_newkeys: mode 1 debug1: rekey after 134217728 blocks debug1: SSH2_MSG_NEWKEYS sent debug1: expecting SSH2_MSG_NEWKEYS debug3: receive packet: type 21 debug1: SSH2_MSG_NEWKEYS received debug2: set_newkeys: mode 0 debug1: rekey after 134217728 blocks debug2: key: /home/omar/.ssh/id_rsa ((nil)) debug2: key: /home/omar/.ssh/id_dsa ((nil)) debug2: key: /home/omar/.ssh/id_ecdsa ((nil)) debug2: key: /home/omar/.ssh/id_ed25519 ((nil)) debug3: send packet: type 5 debug3: receive packet: type 7 debug1: SSH2_MSG_EXT_INFO received debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521> debug3: receive packet: type 6 debug2: service_accept: ssh-userauth debug1: SSH2_MSG_SERVICE_ACCEPT received debug3: send packet: type 50 debug3: receive packet: type 51 debug1: Authentications that can continue: publickey,password debug3: start over, passed a different list publickey,password debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password debug3: authmethod_lookup publickey debug3: remaining preferred: keyboard-interactive,password debug3: authmethod_is_enabled publickey debug1: Next authentication method: publickey debug1: Trying private key: /home/omar/.ssh/id_rsa debug3: no such identity: /home/omar/.ssh/id_rsa: No such file or directory debug1: Trying private key: /home/omar/.ssh/id_dsa debug3: no such identity: /home/omar/.ssh/id_dsa: No such file or directory debug1: Trying private key: /home/omar/.ssh/id_ecdsa debug3: no such identity: /home/omar/.ssh/id_ecdsa: No such file or directory debug1: Trying private key: /home/omar/.ssh/id_ed25519 debug3: no such identity: /home/omar/.ssh/id_ed25519: No such file or directory debug2: we did not send a packet, disable method debug3: authmethod_lookup password debug3: remaining preferred: ,password debug3: authmethod_is_enabled password debug1: Next authentication method: password <publicIP>@omar-@omar-Len@192.168.1.2's password: debug3: send packet: type 50 debug2: we sent a password packet, wait for reply debug3: receive packet: type 51 debug1: Authentications that can continue: publickey,password Permission denied, please try again.

This is the debugging from the Laptop:
May 4 14:59:39 omar-Len sshd[10133]: Invalid user <publicIP>@omar-@omar-Len from 192.168.1.8 port 56890 May 4 14:59:44 omar-Len sshd[10133]: pam_unix(sshd:auth): check pass; user unknown May 4 14:59:44 omar-Len sshd[10133]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.1.8 May 4 14:59:47 omar-Len sshd[10133]: Failed password for invalid user <publicIP>@omar-@omar-Len from 192.168.1.8 port 56890 ssh2 May 4 14:59:49 omar-Len sshd[10133]: Connection closed by invalid user <publicIP>@omar-@omar-Len 192.168.1.8 port 56890 [preauth] May 4 15:03:50 omar-Len sudo: omar : TTY=pts/0 ; PWD=/home/omar/Desktop ; USER=root ; COMMAND=/bin/nano //var/log/auth.log May 4 15:03:50 omar-Len sudo: pam_unix(sudo:session): session opened for user root by (uid=0) May 4 15:04:12 omar-Len sudo: pam_unix(sudo:session): session closed for user root

11
  • if sshd is running on both boxes, this might be a firewall issue. Did you look for this ? – tonioc May 2 '20 at 16:53
  • @A.B i have done ss -tn sport = :22 and both showed the same resut state Recv-Q Send-Q Local Ddress:Port Peer Address:Port only, no number or anything else – Omar Shawky May 2 '20 at 17:48
  • @tonioc i do not know how to use firewall in linux, i do not know how to check or what to check in the firewall – Omar Shawky May 2 '20 at 17:51
  • @A.B omar@omar-Len:~/Desktop$ ss -tn | fgrep 192.168 | egrep 'ssh|22' ESTAB 0 0 192.168.1.2:51134 173.194.76.188:5228 ESTAB 0 0 192.168.1.2:22 192.168.1.8:44512 – Omar Shawky May 2 '20 at 18:03
  • 1
    (so if some people read the comments, in the end that's indeed NAT. to be continued...) – A.B May 2 '20 at 18:58
0

When you use tethering on the cellphone, it actually makes a local private network of its own and does NAT and stuff, hiding Desktop behind. That's why Desktop to laptop works fine as laptop is some public network for desktop, being accessible via the phone.

But that is not true for the other way round. There is no way for Laptop or modem can see and reach that network behind cellphone. Tethering has little to no options to cancel NAT and let basic routing to be done, unless you can bridge USB and wireless on it, there is not much you can do.

Any refusal or failed login you get is probably from the router or some hosts outside your network.

So the solution is to let desktop initiate connection all the time.

1
  • yes that is true, after i asked a friend, the only scenario to make it work is to add an exception to firewall and to add a static port to forward it to the device when anyone tried to connect through that port – Omar Shawky May 4 '20 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.