0

I am working on a remote Ubuntu server, from my windows local computer.

I can login to the remote host with mobaxterm, so the password is correct. But the ssh fails.

 ssh -v  naomi1@52.232.64.127
OpenSSH_for_Windows_7.7p1, LibreSSL 2.6.5
debug1: Connecting to 52.232.64.127 [52.232.64.127] port 22.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file C:\\Users\\Naomi Fridman/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\\Users\\Naomi Fridman/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\\Users\\Naomi Fridman/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\\Users\\Naomi Fridman/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\\Users\\Naomi Fridman/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\\Users\\Naomi Fridman/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\\Users\\Naomi Fridman/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\\Users\\Naomi Fridman/.ssh/id_ed25519-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\\Users\\Naomi Fridman/.ssh/id_xmss type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\\Users\\Naomi Fridman/.ssh/id_xmss-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_for_Windows_7.7
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.6p1 Ubuntu-4ubuntu0.3
debug1: match: OpenSSH_7.6p1 Ubuntu-4ubuntu0.3 pat OpenSSH* compat 0x04000000
debug1: Authenticating to 52.232.64.127:22 as 'naomi1'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:Ig1UiMRoK7Kw9HEoS1baYd2PpSeh+GlQtaeFKPKiBBI
debug1: Host '52.232.64.127' is known and matches the ECDSA host key.
debug1: Found key in C:\\Users\\Naomi Fridman/.ssh/known_hosts:1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey after 134217728 blocks
debug1: pubkey_prepare: ssh_get_authentication_socket: No such file or directory
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: C:\\Users\\Naomi Fridman/.ssh/id_rsa
debug1: Trying private key: C:\\Users\\Naomi Fridman/.ssh/id_dsa
debug1: Trying private key: C:\\Users\\Naomi Fridman/.ssh/id_ecdsa
debug1: Trying private key: C:\\Users\\Naomi Fridman/.ssh/id_ed25519
debug1: Trying private key: C:\\Users\\Naomi Fridman/.ssh/id_xmss
debug1: Next authentication method: password
debug1: read_passphrase: can't open /dev/tty: No such file or directory
naomi1@52.232.64.127's password:

I enter the correct password, but it fails:

debug1: Authentications that can continue: publickey,password
debug1: No more authentication methods to try.
usr@host: Permission denied (publickey,password).

I tried to remove ~/.ssh/known_hosts, and I tried to copy it to the server, but it didn't help.

  • are using ssh from a powershell or cmd window? and do you have an authorized_keys file on the ubuntu server with your key in? – fcbsd May 2 '20 at 10:57
0

Try ssh with -t option.

ssh -t user@server.example.com

Also , you can share your client .pub public file to your server ( in yourhomedirectory/.ssh/authorized_keys ) and try with public key method without password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.