1

I just upgraded from Fedora 30 to Fedora 32 directly using the commands specified in the upgrading guide. Note that I used --allowerasing

sudo dnf system-upgrade download --releasever=32 --allowerasing

When I try to reboot using any of my Fedora releases (I am using a dual boot with Windows Boot Manager on a laptop), I get the following error:

[FAILED] Failed to start Switch Root.

When running systemctl status initrd-switch-root.service I get:

Failed to switch root: Specified switch root path '/sysroot' does not seem to be an OS tree. os-release file is missing.

/sysroot is indeed an empty folder, link to os-release is missing, but I still have /usr/lib/os-release with correct content, it seems.

Following some solutions I found online, I tried:

mkdir -p /sysroot/etc
cp /usr/lib/os-release /sysroot/etc/
reboot

But on reboot, I keep getting same error. I also tried inspired on another bug report:

mount -o remount,rw /sysroot
cd /sysroot/usr/lib
ln -s os.release.d os-release.d   
exit

But the first line returns mount point not mounted or bad option. When I try to manually create the symlink to /usr/lib/os-release and reboot, it's not there anymore and I get error again.

Any idea on how to solve this? It would be an immense help, thanks!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.