I've been trying to install archlinux on xps one. the screen doesn't work because it has intel g45/g43 express chipset. I had to use nomodeset option as mentioned in the installation guide. Arch somewhat booted but i get an error:

:: Mounting '/dev/disk/by-label/ARCH_201212' to '/run/archiso/bootmnt'
Waiting 30 seconds for device /dev/disk/by-label/ARCH_201212 ...
ERROR: '/dev/disk/by-label/ARCH_201212' device not show up after 30 seconds.
   Falling back to interactive prompt
   You can try to fix the problem manually, log out when  you are finished
sh: can't access tty; job control turned off
(had to write it by hand)

none off the commands in the installation manual worked. including parted and fdisk. the commands are just missing. the interesting thing is that archbang booted.

My main question is how do i get into arch's installation environmental so i have commands like parted.

It might help me if I can find out what environment i'm in. for example, less, mount works but more doesn't.

PS: i tried to post it on arch forums but the registration process is broken.

Update (1) i tried to chroot https://wiki.archlinux.org/index.php/Install_from_Existing_Linux#Method_2:_Chroot_into_LiveCD-image but

sh: unaquashfs: not found

Update (2) if during boot menu. i prress Tab, i get:

> /linux boot/x86_64/vmlinuz archisobasedir=arch archisolabel=ARCH_201212 initrd=boot/x86_64/archiso.img

to get to command prompt, i have to add nomodeset

  • The commands don't work because it can't find your installation medium and falls back to a ramdisk. Did you change the install medium's filesystem label? – Chris Down Dec 12 '12 at 23:05
  • @ChrisDown no, didn't change anything. i'm not sure where i cal look it up – kirill_igum Dec 12 '12 at 23:23
  • @ChrisDown Is there any place where I can find out what correct labels I should use? – kirill_igum Dec 12 '12 at 23:25
  • How did you create the installation medium? – UldisK Dec 15 '12 at 16:50

First, check this post: https://bbs.archlinux.org/viewtopic.php?id=142473

They mention something about specifying the wrong device when creating the disk. In particular, maybe you used /dev/sdx1 instead of /dev/sdx

If that doesn't help, I suggest you try the two options to create the live USB they give in their wiki: https://wiki.archlinux.org/index.php/USB_Installation_Media

Then, if it keeps failing, try Unetbootin to generate the bootable USB.

If you still can't make it work, try either using ArchBang (fastest option), the Netboot image, or an older snapshot of Arch (not too old, or it won't have systemd).

Finally, if all of the above failed, cry yourself to sleep and install another distribution when you wake up :)

| improve this answer | |
  • thanks for the informative answer. makes sense. for now i chose the last option and got vista. at some point i'll try to dual-boot arch . – kirill_igum Dec 17 '12 at 17:36

Not sure if this'll work, since Arch shouldn't have any problem with this. But if you created your USB key under Windows (it may happen on other OSs as well, I don't know), its name may be shorter that the one Arch is seeking.

For example, when I tried to install Architect, the boot process expected the name to be architect-201601-64bit, while Windows named it ARCHITECT-2.

I'm saying you shouldn't have any problem with Arch because this shouldn't happen, since ARCH_201212 is way shorter.

First you probably want to try a ls /dev/disk/by-label/ to check the key name. If its name is different, just do the command mv /dev/disk/by-label/<key name> /dev/disk/by-label/ARCH_201212 (replace by your version name obviously). Then type exit, and the boot process goes on just fine.

Finally, I might add that it might not be a problem anymore, since the question was asked 3 years ago. But if this issue still happens, I'd rather post this in case it actually helps someone.

| improve this answer | |

The root cause of the observed problem is explained here: https://github.com/pbatard/rufus/issues/713#issuecomment-196901835

This is present all over the linux eco-system. They lack understanding of how things work (in this case FAT filesystem), but they find one single way to make it work (using Rufus or other software that would fix their mess on-the-fly).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.