21

The touchpad on my laptop is a poor design, because it doesn't recede down into its housing to avoid my thenar and hypothenar's proclivity for inadvertent tap-to-clicks.

In Ubuntu 19.10, using this same laptop, I was able to toggle off "Tap to Click", as shown here.

However, in Kubuntu 20.04, this option is grayed out (disabled), and cannot be Toggled:

enter image description here

Is there another way that I might disable Tap-to-Click, given that the GUI isn't offering the ability to toggle this setting?

9
  • 3
    bug 420762 Apr 29, 2020 at 17:24
  • I have the same issue. Dell XPS9360 running Kubuntu 20.04. I see you filed a bug on this here. You added a comment to you bug report that there is a workaround but that just links back to this page where I do not see any mention of a workaround. Am I missing something? Thanks. May 3, 2020 at 11:45
  • @rodoherty1 : No, you're not missing anything. I anticipated someone here would have provided a workaround quickly, but it hasn't happened yet. Sorry for the confusion; you can't edit bug comments at KDE. May 4, 2020 at 3:51
  • 2
    @Vince I just took a look at my Tap-to-click settings, and I too was unable to toggle that check box due to it being disabled. I enabled the ability to toggle it in an unusual way. Basically, I click the "Default" button on the bottom-left, but I did NOT apply it. Instead, I exited out of the Touchpad settings window. Upon doing that it ask me if I wanted to save the changes I made, and clicked "Discard". After that, I went back into the touchpad settings again (from a freshly launched window) and for some reason the "Tap-to-click" became toggleable. Oct 7, 2020 at 4:12
  • 1
    See comment 5. @Vince Oct 7, 2020 at 4:36

5 Answers 5

15

Referance: https://askubuntu.com/questions/1179275/enable-tap-to-click-kubuntu

I had to add Option "Tapping" "True" to the entry MatchIsTouchpad in the file /usr/share/X11/xorg.conf.d/40-libinput.conf. The exact name of the file might be different for other people.

In the end, the relevant section will look like something like this:

Section "InputClass"

        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        Option "Tapping" "True"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

You need to be root to edit the file and reboot your system after the changes!

3
  • 1
    This is not Kubuntu specific, seen and fixed it in Fedora.
    – cipricus
    Mar 23, 2021 at 12:22
  • 1
    This did not work for me, using Kubuntu 22.04, trying to disable tap to click via setting False and rebooting... no change observed
    – Erik
    Jul 6, 2022 at 7:26
  • Still works in 2023) Thanks Sep 1, 2023 at 23:36
14

I had this same issue on a Razer Blade 15 (mid-2021) running Kubuntu 20.04 LTS.

The fix for me was to install the synaptics touchpad driver.

sudo apt update
sudo apt install xserver-xorg-input-synaptics

Reboot

3
  • For Ubuntu based distributions the right answer. In KDE Neon (22.04LTS) it activates tap-to-click by default and the Touchpad settings page is totally renewed with many more settings.
    – ñull
    Dec 15, 2022 at 12:55
  • Can confirm for Kubuntu 22.04 on Lenovo T580 Dec 25, 2023 at 10:12
  • Thanks, this fixed the issue on my Acer Swift 3 Laptop running Kubuntu 23.10 Mar 9 at 11:37
4

Currently, June 2022, using Arch Linux with KDE/Plasma desktop environment, to solve the issue simply install the generic driver for X.Org, based on libinput, and reboot the system:

sudo pacman -S xf86-input-libinput

Or the specific Synaptics driver:

sudo pacman -S xf86-input-synaptics

EDIT: On october 2022 I've realized that the above did not work anymore on Arch Linux with KDE/Plasma. Consider also that xf86-input-synaptics is no longer actively updated (See https://wiki.archlinux.org/title/Touchpad_Synaptics) and it is advised to use libinput instead.

Installing both the libinput and the libinput-gestures (this is from AUR) packages on Arch Linux, definetely solved the issue:

Install the former with:

sudo pacman -S libinput

and the latter with an AUR helper:

yay -S libinput-gestures
2

My reputation does not allow me to comment to the answer by @Dimutha, so posting as an answer:

follow the instructions from this answer, but use

        Option "Tapping" "on"

i.e., use "on" instead of "True".

I'm running plasmashell 5.24.6, KDE Framework 5.92.0, Ubuntu 22.04.

0

For people on Fedora, AlmaLinux, Rocky and others RedHat distros.

Put the below in /usr/share/X11/xorg.conf.d/40-libinput.conf note that the file should not be empty. Further info can be found here https://docs.fedoraproject.org/en-US/quick-docs/enable-touchpad-click/

Section  "InputClass"
    Identifier  "touchpad overrides"
    # This makes this snippet apply to any device with the "synaptics" driver
    # assigned
    MatchDriver  "synaptics"

    ####################################
    ## The lines that you need to add ##
    # Enable left mouse button by tapping
    Option  "TapButton1"  "1"
    # Enable vertical scrolling
    Option  "VertEdgeScroll"  "1"
    # Enable right mouse button by tapping lower right corner
    Option "RBCornerButton" "3"
    ####################################

EndSection
2
  • 1
    The linked page describes how to enable touchpad click. This question asks how to disable it. Why do you believe that the instructions that you quote will do what this question asks for? Mar 6 at 17:12
  • It makes the option toggleable in the UI so you can turn it off using this method. You could also change the value to 0 instead of 1.
    – Michael
    Mar 8 at 8:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .