I recently installed dwm (a linux window manager) which extensivley uses Alt+Shift key combinations for navigation but none of them are working. For example Alt+Shift+c will close a window.

I installed screenkey to check if my keyboard was working and saw that when I pressed Alt+Shift it registered as Alt+ISO_Next_Group. When I pressed Alt+Shift+c it registered as Alt+ISO_Next_Group then Alt+c.

I found this Arch Wiki page which mentions ISO_Next_Group but does not seem to suggest any solutions. What can I do to get Alt+Shift working again?

4 Answers 4


This is yet another computing mis-use of "ISO" without specifying the actual International Organization for Standardization standard number. In this case it is ISO/IEC 9995-2:2009.

Pressing ⇧ Level 2 Shift+⇮ Level 3 Shift and then releasing that chord is one of the standard ways of providing an equivalent for a ⇨ Group 2 Select key on systems like USB Human Input Devices which do not directly allow for such a key. Usually this enables access to a common second group which has a common layout that supplies a whole bunch of stuff and remains the same whilst the group 1 layout of your keyboard varies.

But this should not involve the ⎇ Alt key. Conventionally, ⇮ Level 3 Shift is ⇮ AltGr at position A08, not ⎇ Alt at position A01. You should, if the standard mechanism has been provided correctly, still be able to input the chords that you want with the ⎇ Alt key, e.g. ⇧ Level 2 Shift+⎇ Alt+C.

Where this all happens is your X keyboard map, which is what that Arch Wiki page is discussing. If ⎇ Alt is being erroneously conflated with ⇮ AltGr then your keyboard map needs fixing. Otherwise you should be able to type the chords as aforementioned.

So you have three options:

  1. Keep your current keyboard map and use ⇧ Level 2 Shift+⎇ Alt in chords instead of ⇧ Level 2 Shift+⇮ AltGr.
  2. Fix your current keyboard map so that it does not treat ⎇ Alt as ⇮ AltGr, and proceed as #1. Since your choice of window manager, dwm, is user configured by manually altering the source code and recompiling the program, compiling and applying an XKB map shouldn't be very daunting. ☺
  3. Switch your keyboard map, using whatever mechanism your system has for switching XKB maps, to one that is already fixed, or (less preferably, in my view) to one that does not actually have ⇨ Group 2 Select.

Further reading


You need to go to the shortcuts and change there what you want to do. You need to find the keyboard section in the search and then find the shirtcuts. There you can replace Alt+Shift with what you want to use as shortcut

  • I don't have a "shortcuts"
    – ayNONE
    Commented Apr 27, 2020 at 9:51

My issue was actually particular to MX-Linux. By default the "Layout Switch" key is set to Alt+Shift. You can change this in fskbsettings which is installed by default.


For those of you who ended up here, but are on Ubuntu 22.04 - I had the same problem (triggering of ISO_Next_Group interfered with my PyCharm shortcuts).

I removed all secondary languages from my inputs list, it didnt help. I checked that the language switch keyboard shortcut was set to Super+Space in settings->keyboard->customise shortcuts, it didnt help.

I checked in gnome 'tweaks' -> Keyboard & Mouse -> Additional Layout options, and sure enough, Shift+Alt was checked. I unchecked it, and enabled win+space. (left_alt-based) Shortcuts work now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .