The dialog box Bigger

I was configuring my KDE + i3wm hybrid setup and after adding a custom ~/.xsession(which is this commit), I keep seeing a small dialog box which appears after I enter a correct password. When I click on Okay, it properly logs me to my XSession as well.

I'd like to point out that earlier, I was using .desktop files to create an xsession using Exec=env KDEWM=/usr/bin/i3 /usr/bin/startplasma-x11 which didn't produce this behaviour.

Could you please tell me what this dialog box is, and how to remove it?


Upon further investigation, I've found out that the process is xmessage. Now the question is why it's opening and how to disable xmessage from opening on login.


1 Answer 1


I've finally figured out what caused it. In my .xinitrc I had an unnecessary startx command, which was getting executed after KDE. The message was simply displaying that X server was already running or something of that sort(I'm being unclear because I couldn't see the exact message).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .