I need a dual boot in my computer, Windows 7 and Fedora 17. I first installed Windows 7 and created the partition scheme during Windows install: - Partition 1: is a small partition automatically created by Windows when I create a partition (around 100MB) - Partition 2: Partition where I will install Windows 7. - Partition 3: Free space where I will install Fedora.

Everything works fine with Windows. Then I install Fedora, I create another partition for boot (around 500MB) and another logical partitions for swap and root (actually Fedora creates those partitions in the free space).

After all the installation the system shows a warning message: There was an error installing the bootloader. The system may not be bootable.

In fact, the system is not bootable. After the installation the computer always boots into Windows.

The weird thing is that I installed both systems several days ago and I had do reinstall both OSs, but not sure what is happening now.

Note: I also tried installing Grub2 with the live cd, but I have several problems with that, so may me is easier to solve the issue of the bootloader.

closed as too localized by jasonwryan, Michael Mrozek Feb 8 '13 at 5:21

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • What sort of problems did you run into while installing grub2 from LiveCD? – Joseph R. Dec 12 '12 at 17:36
  • /usr/share/grub/grub-mkconfig_lib: line 53: 1830 Segmentation faul (core dumped) "${grub_probe}" -t fs "$path" > /dev/null 2>&1 Path '/boot/grub2' is not readable by GRUB on boot. Installation is impossible. Aborting. – Jose Daniel Dec 12 '12 at 22:20
  • Describe your hardware. – Michael Hampton Jan 12 '13 at 19:38
  • Segfaults could be from bugs, or from hardware problems. Have you tried memtest86? – derobert Feb 7 '13 at 22:19

What format is your boot partition? If you're using GRUB 2, it should be ext3 or ext4. Had a similar problem until I went through GRUB 2 documentation and found it no longer supported ext2.

Partiton 1 that Windows create is Windows bootloader. In this setup you'll need to install EasyBCD or another program to handle the choice of your OS

  • 1
    I'm using GRUB2 and ext4. – Jose Daniel Dec 12 '12 at 20:51
  • Then my suggestion holds no water :) I would suppose it isn't related to this bug, depends on the version of Fedora - link You could try with just GRUB and see if that goes. Sorry I can't help you more. Only one more thing, is it LVM or standard installer partitions? – sachiel6 Dec 15 '12 at 19:36
  • LVM partitions. – Jose Daniel Feb 7 '13 at 17:42

Well, the only way I could fixed it was installing Fedora 16 and upgrading it to Fedora 17.

Not the answer you're looking for? Browse other questions tagged or ask your own question.