0

I need to set up a FTP server within my Ubuntu virtual box but im having problems within configuration of the config file within VSFTPD

From online tutorials i keep seeing different options being selected and different reasoning, i just need a simple and secure configuration without enable settings i do not understand.

So far i have selected to use the following options within /etc/vsftpd.conf

Listen=NO
Anonymous_enable=NO
Local_enable=YES
wrtite_enable=YES
dirmessage_enable=YES
use_localtime=YES
connect_from_port_20=YES
xferlog_enable=YES
ftpd_banner=Welcome to Toms FTP Server.
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list

From my understanding thse options do the following:

listen enables standalone, anonymous denies non verified login, write enable allows to write files, dir message is directory explaining, local time is the time used for dating files, port 20 is self explanatory, xferlog is a log creation/format type?, banner is self explanatory, chroot specifies users are restricted to their directory, users not restricted to their directory are listed within chroot_list.

The problem i am having is i keep seeing reference on tutorials regarding a userlist which will state which users do have access like this:

user_sub_token=$USER
local_root=/home/$USER/ftp
userlist_enable=YES
userlist_file=/etc/vsftpd.userlist
userlist_deny=NO

This does not exist in my file and whenever i try to enter it manually it causes my VSFTPD to fail start up when restarting, i see this in almost every tutorial but it is not contained within my configuration files???

Am i trying to configure this wrong?

What is the minimum requirements for a safe VSFTPD configuration?

Is this user list no-longer supported?

Do i even need this user list?

error code also does not disappear removing these files and restarting again, it completely breaks the service and requires a re installation every single time, the error code is as follows:

systemctl status vsftpd.service

● vsftpd.service - vsftpd FTP server
   Loaded: loaded (/lib/systemd/system/vsftpd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2020-04-26 13:58:09 UTC; 14min ago
  Process: 30588 ExecStart=/usr/sbin/vsftpd /etc/vsftpd.conf (code=exited, status=2)
  Process: 30584 ExecStartPre=/bin/mkdir -p /var/run/vsftpd/empty (code=exited, status=0/SUCCESS)
 Main PID: 30588 (code=exited, status=2)

Apr 26 13:58:09 ubuntu systemd[1]: Starting vsftpd FTP server...
Apr 26 13:58:09 ubuntu systemd[1]: Started vsftpd FTP server.
Apr 26 13:58:09 ubuntu systemd[1]: vsftpd.service: Main process exited, code=exited, status=2/INVALIDARGUMENT
Apr 26 13:58:09 ubuntu systemd[1]: vsftpd.service: Failed with result 'exit-code'.

1 Answer 1

0

Comment out (or delete) use_localtime, and try again.

#use_localtime=YES
2
  • It would be helpful to OP if you explain why you think this will fix the issue. OP has stated a reason for including it.
    – bu5hman
    Oct 9, 2020 at 15:08
  • I get a similar issue. I started with a working config file, then added my settings one by one, until I found which one was the culprit. I cannot explain why this one does not make the vsftpd service not to start.
    – malagasy
    Oct 9, 2020 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.