1

I'm having trouble enabling IOMMU on Centos 8 (4.18.0-147.8.1.el8_1.x86_64) and I'm starting to think that my CPU doesn't support VT-d.

On the Intel ARK page for my CPU it says "yes" for VT-x and VT-d but there is also the following sentence:

This product includes VT-d support only on the C2 stepping. Stepping information can be viewed via the menu on the left.

I have no idea what the "menu on the left" is" but if I look for the stepping of my CPU I get the following:

$ cat /proc/cpuinfo | grep stepping
stepping    : 7

My question:

Does "stepping 7" comes before or after "stepping C2"?


More info:

I have the following UEFI settings:

  • Intel Virtualization Technology: Enabled
  • Intel(R) I/OAT: Disabled
  • Intel(R) VT-d: Enabled
  • and everything else enabled (except Limit CPUID Maximum which is Disabled)

To check if IOMMU is enabled I tried:

$ dmesg | grep -E "DMAR|IOMMU"

and

$ virt-host-validate

which returns:

ARN (IOMMU appears to be disabled in kernel. Add intel_iommu=on to kernel cmdline arguments)

Settings I tried to append to GRUB_CMDLINE_LINUX in /etc/default/grub:

  • intel_iommu=on
  • intel_iommu=on iommu=pt
  • intel_iommu=on iommu=pt iommu=1

Then apply the changes to grub with:

$ sudo grub2-mkconfig -o /boot/grub2/grub.cfg

and

$ sudo dracut --regenerate-all --force

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.