3

I have just installed Ubuntu 20 Mate. When I try to boot it, the process is blocked at loading initial ramdisk. I already tried to reinstall it. What could be the problem? I am using a Dell Inspiron 15 5567 with Intel i7-9700U, 16Gb RAM, AMD R7 M445 dedicated GPU. These are my partitions:

Disk /dev/sda: 238.49 GiB, 256060514304 bytes, 500118192 sectors
Disk model: SanDisk X400 2.5
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 8BF721E2-AA3C-43E8-A8B0-1B608E93C690

Device         Start       End   Sectors   Size Type
/dev/sda1       2048     34815     32768    16M Microsoft reserved
/dev/sda2      34816 346265599 346230784 165.1G Microsoft basic data
/dev/sda3  346265600 347469823   1204224   588M Windows recovery environment
/dev/sda4  437407744 496001023  58593280    28G Linux filesystem
/dev/sda5  496001024 500117503   4116480     2G EFI System
/dev/sda6  435453952 437407743   1953792   954M Linux swap

Partition table entries are not in disk order.

The first three partitions are related to Windows, including Windows Boot Manager. Grub is installed in sda5. I am using UEFI.

0

3 Answers 3

2

As written in the answers to this question on AskUbuntu, I disabled PPT security in the UEFI settings:

For those who are new to the BIOS, press F2 when you see the Dell logo, go to SecurityPTT Security and uncheck PTT On. Click Apply (I would recommend choosing Save as Custom User Settings), then OK, then Exit.

3
  • So did this solved your problem?
    – rubaiat
    Commented Apr 26, 2020 at 3:29
  • @rubaiat yes, it solved my problem
    – SctALE
    Commented Apr 26, 2020 at 11:59
  • How could a ubuntu distron have such complex setup to work ? Strange, no? Commented Sep 20, 2023 at 19:01
1

I don't have PTT Security in my BIOS

Adding dis_ucode_ldr to grub helped in my case:

See: https://www.dell.com/community/Precision-Mobile-Workstations/Precision-7540-will-only-boot-Linux-if-charger-is-connected/td-p/7449042/page/3

1
  • I have the booting problem after upgrading to Ubuntu 21.04, but the default options for recovery mode already have dis_ucode_ldr, It also has: ro recovery nomodeset
    – Andrew
    Commented Aug 1, 2021 at 14:37
1

On an Lenovo IdeaPad 330s-15ikb, I upgraded Ubuntu 20.04 to 21.04 after Ubuntu Software Updater prompted me to upgrade, but after the first reboot, my system would stop at "loading initial ramdisk." The kernel option dis_ucode_ldr was already in grub recovery mode, and mitigations=off did not help. Next, I booted from Ubuntu 21.04 in a USB, mounted my solid state drive, and ran apt dist-upgrade and apt update, but then I could boot only once and was back to where I started.

What helped was updating my old Windows 10 (in my other partition) to 1909 and then 20H1. There may have been other firmware, microcode, or UEFI/BIOS updates, but I saw a Lenovo firmware update version 1.17.0.0 dated 3/23/2018. In the beginning, I had BIOS 7SCN17WW, while 7SCN36WW was available, but I did not verify it updated.

Now Ubuntu 21.04 boots fine with zero changes to the Linux side.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .