This computer is not my own, although I am very familiar with it. On the owner's Windows 7 drive Vulkan is functional, however on my own Debian drive it isn't. I've followed the instructions on Debian.org, namely enabling contrib & non-free, and installing
firmware-linux, firmware-linux-nonfree, libgl1-mesa-dri, xserver-xorg-video-ati
and also installed the following packages:
libvulkan-dev, libvulkan1, vulkan-tools, vulkan-utils, vulkan-validationlayers, vulkan-validationlayers-dev, mesa-vulkan-drivers

OpenGL works perfectly fine both in and outside of Steam and its games (covering both i386 and amd64 support), however Vulkan does not start (albeit is installed correctly according to dpkg/apt). I am mainly interested in running Serious Sam Fusion (2017), but also able to test Vulkan's functionality with the much less demanding GZDoom.

Some info:
AMD Radeon HD 295X2 (Vulkan compatible)
Ryzen 1700X
16 GB RAM (DDR4)
(any other nessesary info always available)

$ vkcube

vkcube: /build/vulkan-tools-6bmpQy/vulkan-tools-1.1.97+dfsg1/cube/cube.c:3148: 
demo_init_vk: Assertion `!err' failed.

$ vulkaninfo

Vulkan Instance Version: 1.1.97


$ dpkg -l | grep amdgpu

ii  libdrm-amdgpu1:amd64                   2.4.97-1
ii  libdrm-amdgpu1:i386                    2.4.97-1
ii  libgbm1-amdgpu-pro-base                16.40-348864
ii  libgl1-amdgpu-pro-appprofiles          16.40-348864
ii  libgl1-amdgpu-pro-dri:amd64            16.40-348864
ic  libgl1-amdgpu-pro-glx:amd64            16.40-348864
ii  opencl-amdgpu-pro-icd:amd64            16.40-348864
ii  xserver-xorg-video-amdgpu              18.1.99+git20190207-1

$ glxinfo | grep OpenGL

OpenGL vendor string: X.Org
OpenGL renderer string: AMD HAWAII (DRM 2.50.0, 4.19.0-8-amd64, LLVM 7.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.6
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5 (Compatibility Profile) Mesa 18.3.6
OpenGL shading language version string: 4.50
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.3.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
  • Did you install mesa-vulkan-drivers? Try sudo apt install mesa-vulkan-drivers.
    – bardo2
    Apr 25 '20 at 19:44
  • i did just now (for the first time), unfortunately still got errors. I've updated vulkaninfo and vkcube in the question Apr 26 '20 at 4:33
  • Try this tutorial linuxconfig.org/… and add '--reinstall' at the end in case you have already installed some packages. Maybe we missed some package.
    – bardo2
    Apr 26 '20 at 10:54
  • @bardo2 followd the instructions, --reinstall'ed all the packages (the only new one ended up being firmware-linux, not the non-free one the regular one. Unfortunately, vkcube and vulkaninfo show the same information as previously Apr 27 '20 at 18:40
  • is there any place i can check if the R9 295X2 does in fact support vulkan in linux? the card should be compatible (it is well above OpenGL ES 3.1) and ironically vulkan does work fine in windows I appreciate the help so far! Apr 27 '20 at 18:41

I ended up installing the latest amdgpu (not amdgpu-pro) from the AMD site. If doing this, make sure you download drivers newer than "Radeon Crimson 15.12" as that is the last version of fglrx (not something you want), but instead a newer version.

Turns out the cause was that AMD has a line of graphics cards (approximately Radeon HD 7000 series to R9 Fury X) in which the old radeon kernel driver as well as the new amdgpu kernel driver support, giving users the option to use either. To switch from one to the other is explained here on this Debian Wiki page (its only a couple commands for GRUB).

However my solution instead was to install the latest amdgpu kernel driver from the AMD site instead of relying on the somewhat dated one provided with the Debian kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.