1

Im trying to get the USB/Smartcard (Datev Smartcard Reader) redirected to my Windows Server 2019 Remote Desktop Service from my Fedora 31 machine. I tried rdesktop and xfreerdp but none of them are showing the results im looking for.

What have i tried:

  • I installed opensc ccid pcsc-lite pcsc-tools and started the pcscd service in order to get it working in fedora. (Even if i think this is not necessary because its a Smartcard Reader not the smartcard)
  • I tried to redirect it with rdesktop with the following commands: rdesktop -u $USER -d WINDOWS -r scard rds.my.tld, here the conecction got stuck in the windows login screen. When i removed the -r scard everything worked well so there must be a problem with this switch somehow.
  • I tried to redirect it with xfreerdp with the following commands:

    xfreerdp -d WINDOWS -u $USER /usb:dbg,dev:VENDOOR:DEVICE rds.my.tdl

    xfreerdp -d WINDOWS -u $USER /usb:rules:allow rds.my.tdl

    xfreerdp -d WINDOWS -u $USER /usb:auto rds.my.tdl

    xfreerdp -d WINDOWS -u $USER /usb:VENDOOR:DEVICE rds.my.tdl

    xfreerdp -d WINDOWS -u $USER /smartcard rds.my.tdl

With xfreerdp every session worked well but no device was visible anywhere. scardsvr on Windows is enabled and started. I installed all datev tools to make sure drivers are correctly installed. And even tried a normal usb data stick. That did not work too. I have no clue anymore. Am i missing something in windows?

# xfreerdp --version
This is FreeRDP version 2.0.0-dev5 (n/a)

# rdesktop --version
Version 1.9.0. Copyright (C) 1999-2016 Matthew Chapman et al.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.