1

Do as manual say in webpage wiki to install wine in debian

sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
echo "deb https://dl.winehq.org/wine-builds/debian/ stretch main" |sudo tee -a  /etc/apt/sources.list
sudo apt update

Now install wine :

sudo apt install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 5.0.0~stretch)
E: Unable to correct problems, you have held broken packages.

Try to install wine-stable.

sudo apt install --install-recommends wine-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-stable : Depends: wine-stable-i386 (= 5.0.0~stretch)
E: Unable to correct problems, you have held broken packages.

So many dependencies.

sudo apt install  wine-stable-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-stable-i386:i386 : Depends: libasound2-plugins:i386 but it is not going to be installed
                         Recommends: libglu1-mesa:i386 but it is not going to be installed or
                                     libglu1:i386
                         Recommends: libsdl2-2.0-0:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Some configuration in my os.

cat /etc/issue
Debian GNU/Linux 9 \n \l
ls /etc/apt/sources.list.d
google-chrome.list  google-chrome.list.save  wine-obs.list
cat  /etc/apt/sources.list.d/wine-obs.list
deb http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_9.0 ./

It is no use to remove it. enter image description here Dependencies issue remains.
enter image description here It is no use to sudo apt dist-upgrade.

enter image description here Remove the package to check.

sudo apt purge wine.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libwine-dev' for regex 'wine.'
Note, selecting 'winetricks' for regex 'wine.'
Note, selecting 'wine-devel-amd64' for regex 'wine.'
Note, selecting 'wine-staging-compat' for regex 'wine.'
Note, selecting 'wine-devel' for regex 'wine.'
Note, selecting 'wine-binfmt' for regex 'wine.'
Note, selecting 'wine32-preloader:i386' for regex 'wine.'
Note, selecting 'gnome-wine-icon-theme' for regex 'wine.'
Note, selecting 'wine32-development-tools' for regex 'wine.'
Note, selecting 'wine-devel-dbg' for regex 'wine.'
Note, selecting 'wine-devel-dev' for regex 'wine.'
Note, selecting 'wine64-development' for regex 'wine.'
Note, selecting 'wine-stable-dbg' for regex 'wine.'
Note, selecting 'wine-stable-dev' for regex 'wine.'
Note, selecting 'winehq-devel' for regex 'wine.'
Note, selecting 'wine1.4-amd64' for regex 'wine.'
Note, selecting 'wine-staging-i386' for regex 'wine.'
Note, selecting 'wine64-preloader' for regex 'wine.'
Note, selecting 'wine64-development-tools' for regex 'wine.'
Note, selecting 'wine1.6-dev' for regex 'wine.'
Note, selecting 'wine1.4' for regex 'wine.'
Note, selecting 'wine1.5' for regex 'wine.'
Note, selecting 'wine1.6' for regex 'wine.'
Note, selecting 'wine1.7' for regex 'wine.'
Note, selecting 'wine1.8' for regex 'wine.'
Note, selecting 'wine1.9' for regex 'wine.'
Note, selecting 'wine1.5-amd64' for regex 'wine.'
Note, selecting 'wine2.0' for regex 'wine.'
Note, selecting 'wine32-development' for regex 'wine.'
Note, selecting 'wine-devel-i386' for regex 'wine.'
Note, selecting 'wine1.7-i386' for regex 'wine.'
Note, selecting 'wine1.6-amd64' for regex 'wine.'
Note, selecting 'wine-development' for regex 'wine.'
Note, selecting 'wine32-tools' for regex 'wine.'
Note, selecting 'wine1.6-i386' for regex 'wine.'
Note, selecting 'wine-stable' for regex 'wine.'
Note, selecting 'libwine-development-dev' for regex 'wine.'
Note, selecting 'shiki-wine-theme' for regex 'wine.'
Note, selecting 'wine32' for regex 'wine.'
Note, selecting 'wine64' for regex 'wine.'
Note, selecting 'wine1.5-i386' for regex 'wine.'
Note, selecting 'libwine-development' for regex 'wine.'
Note, selecting 'winehq-stable' for regex 'wine.'
Note, selecting 'wine-staging' for regex 'wine.'
Note, selecting 'wine-i386' for regex 'wine.'
Note, selecting 'wine1.4-i386' for regex 'wine.'
Note, selecting 'wine-staging-dbg' for regex 'wine.'
Note, selecting 'wine64-development-preloader' for regex 'wine.'
Note, selecting 'wine-staging-dev' for regex 'wine.'
Note, selecting 'libwine-gecko-2.47' for regex 'wine.'
Note, selecting 'wine-stable-i386' for regex 'wine.'
Note, selecting 'wine-staging-amd64' for regex 'wine.'
Note, selecting 'winehq-staging' for regex 'wine.'
Note, selecting 'wine1.7-amd64' for regex 'wine.'
Note, selecting 'wine-stable-amd64' for regex 'wine.'
Note, selecting 'wine-amd64' for regex 'wine.'
Note, selecting 'wine64-tools' for regex 'wine.'
Note, selecting 'libkwineffects9' for regex 'wine.'
Note, selecting 'wine32-development-preloader:i386' for regex 'wine.'
Note, selecting 'wine32-tools:i386' instead of 'wine32-tools'
Note, selecting 'wine32-development-tools:i386' instead of 'wine32-development-tools'
Package 'wine1.8' is not installed, so not removed
Package 'wine1.9' is not installed, so not removed
Package 'wine1.6-dev' is not installed, so not removed
Note, selecting 'wine32-development:i386' instead of 'wine32-development'
Package 'libwine-gecko-2.47' is not installed, so not removed
Package 'wine2.0' is not installed, so not removed
Note, selecting 'wine-devel-i386:i386' instead of 'wine-devel-i386'
Note, selecting 'wine-stable-i386:i386' instead of 'wine-stable-i386'
Note, selecting 'wine-staging-i386:i386' instead of 'wine-staging-i386'
Package 'gnome-wine-icon-theme' is not installed, so not removed
Package 'libkwineffects9' is not installed, so not removed
Package 'shiki-wine-theme' is not installed, so not removed
Package 'libwine-development' is not installed, so not removed
Package 'libwine-development-dev' is not installed, so not removed
Package 'wine-development' is not installed, so not removed
Package 'wine64-development' is not installed, so not removed
Package 'wine64-development-preloader' is not installed, so not removed
Package 'wine64-development-tools' is not installed, so not removed
Package 'wine32-development-preloader:i386' is not installed, so not removed
Package 'winetricks' is not installed, so not removed
Package 'libwine-dev' is not installed, so not removed
Package 'wine-binfmt' is not installed, so not removed
Package 'wine64' is not installed, so not removed
Package 'wine64-preloader' is not installed, so not removed
Package 'wine64-tools' is not installed, so not removed
Package 'wine32-preloader:i386' is not installed, so not removed
Package 'wine-devel-amd64' is not installed, so not removed
Package 'wine-devel-dbg' is not installed, so not removed
Package 'wine-devel-dev' is not installed, so not removed
Package 'wine-devel' is not installed, so not removed
Package 'wine-stable-amd64' is not installed, so not removed
Package 'wine-stable-dbg' is not installed, so not removed
Package 'wine-stable-dev' is not installed, so not removed
Package 'wine-stable' is not installed, so not removed
Package 'wine-staging-amd64' is not installed, so not removed
Package 'wine-staging-compat' is not installed, so not removed
Package 'wine-staging-dbg' is not installed, so not removed
Package 'wine-staging-dev' is not installed, so not removed
Package 'wine-staging' is not installed, so not removed
Package 'winehq-devel' is not installed, so not removed
Package 'winehq-stable' is not installed, so not removed
Package 'winehq-staging' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

How to fix it? enter image description here

3
2
+250

The main repository is missing in your sources.list (missing dependencies available in the main repository).

Edit your /etc/apt/sources.list as follows:

deb http://deb.debian.org/debian stretch main
deb-src http://deb.debian.org/debian stretch main

deb http://deb.debian.org/debian-security/ stretch/updates main
deb-src http://deb.debian.org/debian-security/ stretch/updates main

deb http://deb.debian.org/debian stretch-updates main
deb-src http://deb.debian.org/debian stretch-updates main

deb https://dl.winehq.org/wine-builds/debian/ stretch main

Disable all repositories under /etc/apt/sources.list.d/

Then run:

sudo apt update
sudo apt upgrade
sudo apt dist-upgrade
sudo apt install --install-recommends winehq-stable
1
  • I can not solve the dependencies when to run sudo apt install --install-recommends wine-stable.
    – showkey
    Apr 27 '20 at 10:12
1

Whenever I have a situation, where apt complains, I first try, if update installations still work:

apt-get clean && apt-get update &&
  apt-get upgrade && apt-get clean && apt-get autoremove --purge &&
  apt-get dist-upgrade && apt-get clean && apt-get autoremove --purge

If the above doesn't run through, it may contain helpful hints like: Try apt --fix-broken install

So, you could try sudo apt-get -f install. That normally installed missing dependencies for me.

0
apt policy libjbig0:i386
apt policy libjbig0:amd64
sudo apt install  wine
1
  • 2
    Although you have answered you own question, would you mind adding some explanation on why this will solve the problem, so that others facing a similar problem can understand how to apply it to their situation?
    – AdminBee
    Apr 28 '20 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.