0

In mc, Shift+F4 is supposed to open a new file in your selected editor but for some time it has done nothing on my system (previously it worked). Any ideas or pointers for debugging the issue would be appreciated. First, where is Shift+F4 specified? I couldn't find the place

2

The bindings should be in ~/.config/mc/mc.keymap. If you don't have that file, grab a copy from /etc/mc/mc.default.keymap.

Inside that file, look for line EditNew under [panel] section. In my keymap, it is set to F14. Odds are your keyboard function keys only go up F12. MC treats Shift+F3 as F13, Shift+F4 as F14 and so on. (You can confirm that under Options > Learn keys... menu by pressing those keys).

When a binding does not work in a X session, it can be a good idea to log in to a TTY and try the keybinding there. If some other X application were intercepting the signals (as you found to be your case), the keystroke will reach MC in the TTY. But beware! In the TTY Shift+F3 goes to F15 instead of F13!

0

OK, the issue was strange. I'm using Xubuntu Core, i.e. Xfce, and had bound Shift-F4 to trigger my editor (micro) under Xfce's Start > Settings > Keyboard > Application Shortcuts, apparently masking the mc's internal binding. It's strange because I've no recollection of making the binding, and no apparent reason for doing so if mc's internal binding worked. So a wild guess is that once upon a time (I've been using my sys for 2 years) I made the binding because the internal one didn't work but some time after that (for some reason, e.g. after updating mc) both bindings started to function, cancelling each other out

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.