2

I was using lightdm with the lightdm-gtk-greeter just fine, however I tried to install the unity greeter and now it shows me a black screen with a blinking cursor (I have to ctr+alt+1 and login through the shell to get in)

I'm not sure why it doesn't work, the installation completed without any issues, can anyone point me in the right direction? Let me know if I should post anything that'd help debug the problem.

UPDATE: I just tried installing the pantheon greeter and got the same error, webkit greeter works fine though

  • 1
    Showing the contents of /var/log/lightdm/lightdm.log & /var/log/lightdm/x-0.log would be useful in assisting you. – llua Dec 11 '12 at 20:31
  • Thanks, here's my lightdm.log file and x-0.log after trying to loggin using lightdm-pantheon-greeter – Javier Villanueva Dec 12 '12 at 1:31
  • 1
    [+0.20s] DEBUG: Failed to load session file /usr/share/xgreeters/lightdm-pantheon-greeter.desktop: No such file or directory is your problem. could you pastebin the output of ls /usr/share/xgreeters or pacman -Ql $packagethatinstalledlightdm-panthron-greeter? – llua Dec 12 '12 at 1:55
  • ls /usr/share/xgreeters/ outputs lightdm-gtk-greeter.desktop pantheon-greeter pantheon-greeter.desktop looks like there's actually no lightdm-pantheon-greeter.desktop should I rename the existing pantheon-greeter.desktop ? – Javier Villanueva Dec 12 '12 at 3:21
  • Oh actually I changed the greeter-session variable in my lightdm.conf file to pantheon-greeter and it started to work, thanks! – Javier Villanueva Dec 12 '12 at 3:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.