1

I was attempting a full Manjaro update using sudo pacman -Syyu, but at the end, it threw the error:

Error: hook /usr/share/libalpm/hooks/gtk-query-immodules-3.0.hook line 2: invalid value Path
Error: failed to commit transaction (failed to run transaction hooks)
Errors occurred, no packages were upgraded.

How can I fix the hook?

0

1 Answer 1

4

This happens when you don't maintain your system regularly. The quickest fix is to update Pacman by -

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static
sudo ./pacman-static -Syyu

I don't think it is the cleanest way but it should update Pacman without any problem.

Another way to tackle this problem -

sudo nano /usr/share/libalpm/hooks/gtk-query-immodules-3.0.hook

Change Type = Path to Type = File in line 2

Reinstall the kernel, I'm assuming the version

sudo pacman -S kernel419

Run these -

sudo mkinitcpio -P

sudo update-grub

I'd try to update Pacman first and see if the issue gets solved.

1
  • Thank you, rubaiat, that worked perfectly.
    – Ollie
    Apr 23, 2020 at 16:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .