1

I have Debian 10 and installed wine5 using:

sudo apt install --install-recommends winehq-stable

I get these errors when I try to run Notepad++:

0009:fixme:font:get_outline_text_metrics failed to read full_nameW for font L"Ani"!
0009:fixme:win:LockWindowUpdate (0x1004e), partial stub!
0009:fixme:imm:ImmReleaseContext (000100F0, 0110C888): stub
0009:fixme:win:LockWindowUpdate ((nil)), partial stub!
0009:fixme:msg:ChangeWindowMessageFilterEx 0x1004e 4a 1 (nil)
0009:fixme:win:LockWindowUpdate (0x1004e), partial stub!
0009:fixme:win:LockWindowUpdate ((nil)), partial stub!
0009:fixme:ver:GetCurrentPackageId (0x32fe94 (nil)): stub

I think I need to install something else, but I don't know what.

sudo apt list --installed | grep wine

shows

fonts-wine/stable,stable,now 4.0-2 all [installed]
wine-stable-amd64/unknown,now 5.0.0~buster amd64 [installed,automatic]
wine-stable-i386/unknown,now 5.0.0~buster i386 [installed,automatic]
wine-stable/unknown,now 5.0.0~buster amd64 [installed,automatic]
winehq-stable/unknown,now 5.0.0~buster amd64 [installed]

wine version:

wine --version
wine-5.0

If I run winecfg, I get:

wine: Read access denied for device L"\\??\\Z:\\", FS volume label and serial are not available.
0

2 Answers 2

0

Don't have enough reputation to comment, so I type it as an answer:

What repo did you use? It may be the source of the problem. If you don't need any of the new features of v5 you could try v4 of the official Debian 10 repo. On my Debian 10 system, Wine 4.0 is available, or Wine 4.2-development. Also not any version is available in buster backports.

0

I was finally able to install it with this:

sudo apt-get install winehq-stable

So now I get

wine --version
wine-5.15

I'm not exactly sure of the differences between the original command I ran and this one. The original command was the one mentioned on the winehq website for Debian here

https://wiki.winehq.org/Debian

, so I thought it would work. I am now able to use Notepad++, HeidiSQL, etc.

For apt sources, I have this in /etc/apt/sources.list.d/wine.list

deb https://dl.winehq.org/wine-builds/debian/ buster main

and in /etc/apt/sources.list I have

deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10 ./

I'm not sure which one it used.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .