1

I have Debian 10 and currently have wine-4.0 installed. I am trying to use the recommended command to update from here to the latest wine version:

https://wiki.winehq.org/Debian

sudo apt install --install-recommends winehq-stable

When I run the install command above I get this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 5.0.0~buster)
E: Unable to correct problems, you have held broken packages.

sudo apt list --installed | grep wine shows:

fonts-wine/stable,stable,now 4.0-2 all [installed]
libkwineffects11/stable,now 4:5.14.5-1 amd64 [installed,automatic]
libwine-development/stable,now 4.2-4+b1 amd64 [installed]
libwine-development/stable,now 4.2-4+b1 i386 [installed]
libwine/stable,now 4.0-2 amd64 [installed]
libwine/stable,now 4.0-2 i386 [installed]
wine-development/stable,stable,now 4.2-4 all [installed]
wine32-development/stable,now 4.2-4+b1 i386 [installed]
wine32/stable,now 4.0-2 i386 [installed]
wine64-development/stable,now 4.2-4+b1 amd64 [installed]
wine64/stable,now 4.0-2 amd64 [installed]
wine/stable,stable,now 4.0-2 all [installed]

I ran sudo apt update it shows that everything is up to date.

cat /etc/apt/sources.list.d/wine.list shows:

deb https://dl.winehq.org/wine-builds/debian/ buster main

How can I update it?

3

Answer from Winehq forum : FAudio for Debian 10 and Ubuntu 18.04

The problem come from the missing dependency libfaudio0 it is not available on debian 10 repository nor winehq repo. You need to add the opensuse repository.

sudo apt install software-properties-common apt-transport-https
sudo add-apt-repository 'deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10 ./'
wget https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10/Release.key
sudo apt-key add Release.key
sudo apt update
sudo apt install --install-recommends winehq-stable

Thanks to Cybermax, we have FAudio packages on the OBS for Debian 10 and Ubuntu 18.04. The WineHQ wine-devel and wine-staging packages for those distros are built against them and will require them as a dependency. Beginning with Wine 5.0, the wine-stable packages will also require FAudio.

Note: FAudio for Ubuntu 19.10 and later, and Debian bullseye and later, are provided by those distros. If you are unable to install them from your distro repository, ask for help on your distro's forum.

Because FAudio is not part of the Wine Project, the FAudio packages are not distributed from the download server here, but can be obtained directly from the OBS.

Debian 10: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10/

Ubuntu 18.04 and Linux Mint 19.x: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/

1
  • This worked, but I now get this error. Do you know what might be causing it? 0009:fixme:font:get_outline_text_metrics failed to read full_nameW for font L"Ani"! 0009:fixme:imm:ImmReleaseContext (000100F0, 011571D8): stub 0009:fixme:win:LockWindowUpdate (0x1004e), partial stub! 0009:fixme:shell:IQueryAssociations_fnGetString 00000440: unimplemented flags 0009:fixme:shell:IQueryAssociations_fnGetString 00000440: unimplemented flags 0009:fixme:win:LockWindowUpdate ((nil)), partial stub! 0009:fixme:msg:ChangeWindowMessageFilterEx 0x1004e 4a 1 (nil)
    – raphael75
    Apr 21 '20 at 13:34
0

Try using aptitude install winehq-stable instead of apt. It can sort out conflicting packages for you automatically or make suggestions.

You can install aptitude by running apt install aptitude

2
  • Do I need to uninstall the current wine 4 before I run that?
    – raphael75
    Apr 20 '20 at 19:40
  • 1
    i would suggest it, though it is not required.
    – nullnv0id
    Apr 20 '20 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.