0

I would like to Launch "Xfce4-terminal" on boot using Xfce desktop, Xrdp-client, and Centos.

I tried creating a .desktop file under .config/autostart and also tried to set the xfce4-terminal on login from the xfce4 desktop settings as well but still I am unable to launch the terminal on boot.

did the following from the Sessions and startup app from the desktop and it did not work still. However, upon doing so, it created a file under my userspace like the following but it's not starting automatically when doing an RDP to the server.

----
.config/autostart/xfce4-terminal.desktop

[Desktop Entry]

Encoding=UTF-8

Version=0.9.4

Type=Application

Name=xfce4-terminal

Comment=Terminal

Exec=/usr/bin/xfce4-terminal

OnlyShowIn=XFCE;

RunHook=0

StartupNotify=false

Terminal=false

Hidden=false
----

Kindly advise

1 Answer 1

0

This worked for me . Place a file in /etc/xdg/autostart directory with the following contents.

#cat xfce.desktop
[Desktop Entry]
Type=Application
Name=Xfce_terminal
Exec=xfce4-terminal
Terminal=true

Remember this is a global setting and it applies to all the users and there will be no need to manage them separately using '.config' dir on their respective home directories

Additionally you can manage your default window manager in xrdp using the below steps

Place a file named "startwm-bash.sh" in the /etc/xrdp directory with the following contents

cat /etc/xrdp/startwm-bash.sh
#!/bin/bash
XFCE="$(which xfce4-session 2>/dev/null)"
exec "$XFCE"[/code]

Assign executable permission to the file.

Lastly modify the sesman.ini file to use the above script as the default window manager.

vi /etc/xrdp/sesman.ini

Modify the default window manager to look like below

DefaultWindowManager=/etc/xrdp/startwm-bash.sh

Although the path says it is relative to /etc/xrdp, It worked for me after giving the absolute path of the executable.

Restart the xrdp service

service xrdp restart

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .