2

When I run makepkg -cf, I get an error:

==> ERROR: PKGBUILD does not exist.

enter image description here

But if I run makepkg -p PKGBUILD.asc it works.

enter image description here

Can someone explain to me someone why the first doesn't work?

2 Answers 2

2

How I solved it


The problem is that when downloading PKGBUILD, the browser added an unwanted extension to the file which turned out to be PKGBUILD becoming PKGBUILD.asc, the solution is to simply remove the file extension i.e. rename PKGBUILD.asc as PKGBUILD, you may have another extension that does not matter, the important thing is to remove it.

For More Information


makepkg is a script that automates the building of packages Arch. When you use it without telling it which file to build, you are essentially telling it do nothing, which leaves you with the error you see here.

This error explains it is trying to call PKGBUILD which is a package build description file that needs to be made before the package is built by makepkg. When you used the -p flag you are telling makepkg to instead build the package using buildscript in place of PKGBUILD

I highly suggest reading the man page for makepkg by running man makepkg so that you can learn more about this tool for future use. I will link it here for you as well https://www.archlinux.org/pacman/makepkg.8.html

2
  • 1
    thx, i was checking superficial the link that u send thx btw, i said that becouse the readme of the program that i want to install tell me to run makepkg -cf so if i want to run that command what i need to do if is something that need a path or something and not a short command line i ll read not superficial the link that u send. Thx Commented Apr 19, 2020 at 23:46
  • No problem, be sure to mark it as answered so it is easier for others to find that have the same issue.
    – nullnv0id
    Commented Apr 19, 2020 at 23:48
1

August 2023 update, another alternative

If available, try a -bin package option. Whatever you are trying to compile might already be compiled. That is one option, or not...

This has been a problem in the past for various reasons. Consider the forum on Arch...

I was running make -si specifically for yay per the install instructions on GitHub. Searching this out led me to this question, so others might have a question also.

Maybe something worked in the past and maybe some dependency broke an update, et cetera.

I solved the problem by changing from the yay repository to the yay-bin repository, per the same instructions page. That solved it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .