I have a surface pro (6) and I installed ubuntu on an SD Card. Ubuntu is recognized in the UEFI Bios and is set to first choice of boot.

When I start the computer normally, grub starts but prints "minimal BASH like line editing is supported". However, when I enter the bios and select to boot from Ubuntu, Grub boots normally giving me the choice of choosing Windows or Ubuntu. Ubuntu then starts normally

How can I solve this problem to have grub start normally even when i turn on the computer without going through the bios? Also, is there a better User interface in the menu selection for grub? the letters are very tiny

I have grub 2.02

EDIT:More info

sudo efibootmgr -v

BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0000,0005,0001,0002,0003
Boot0000* Windows Boot Manager  HD(1,GPT,3d6e8e5d-938f-46b9-a342-655fc83eb8b0,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...T................
Boot0001* Internal Storage  FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(50670071-478f-4be7-ad13-8754f379c62f)SDD.
Boot0002* USB Storage   FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(50670071-478f-4be7-ad13-8754f379c62f)USB.
Boot0003* PXE Network   FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(50670071-478f-4be7-ad13-8754f379c62f)PXE.
Boot0004* SurfaceFrontPage  FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(4042708a-0f2d-4823-ac60-0d77b3111889)VOL+.
Boot0005* ubuntu    HD(1,GPT,3d6e8e5d-938f-46b9-a342-655fc83eb8b0,0x800,0x82000)/File(\EFI\ubuntu\shimx64.efi)
  • Please run sudo efibootmgr -v in Ubuntu and edit your question to add the output of the command. This will be useful for us to understand your exact UEFI boot configuration.
    – telcoM
    Commented Apr 19, 2020 at 6:54
  • thanks, i added the info. Commented Apr 20, 2020 at 10:27

1 Answer 1


This line describes the current preference order of UEFI boot options:

BootOrder: 0000,0005,0001,0002,0003

According to this, the first choice is currently Boot0000, which is Windows, and Boot0005 = Ubuntu is the second one. Maybe the BIOS boot order display has a bug?

You can use the efibootmgr command to make Ubuntu/GRUB be the first boot option:

sudo efibootmgr -o 0005,0000,0001,0002,0003

However, if your BIOS prefers legacy-style boot options over UEFI native ones, and you had to make several attempts to install Ubuntu, it is possible that you have a broken version of a legacy MBR-style GRUB on disk also, and that could be causing the "minimal BASH-like editing is supported" state, which is known as GRUB rescue mode.

You might try installing the boot-info-script package and then running sudo bootinfoscript. It should produce a /root/RESULTS.txt file, which would describe all the detected bootloaders in your system, both working and broken ones.

Alternatively, you might go into the "minimal BASH-like editing is supported" state, and type two commands: set and ls, and note their output.

Either of the two approaches above might allow the identification of the failing bootloader, so that it can be fixed or removed (if applicable) with minimal risks. Please update your question with more info if the advice given so far won't solve the problem.

If you go to GRUB command prompt at boot, and use the videoinfo command, you should get a list of display resolutions supported by the UEFI firmware. You could then add a line to /etc/default/grub to define the resolution you want, like this:


After editing /etc/default/grub, you should always run

sudo update-grub 

to make the changes effective.

Your distribution may also have several GRUB themes available, which can change the font used in the GRUB menus. I think a Surface Pro has a high-DPI display, so a high-definition theme with a large font might improve the usability of the GRUB menu.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .