1

To do a backup of my encrypted filesystem, I did zfs send -w fs@snap | zfs receive fs2/root (It was the only snapshot; I hadn't known better and created my source filesystem on the root level).

Now I can't seem to access the data on fs2/root. The keylocation property says prompt when really it should be file:///.... I tried to follow this advice and do zfs change-key -i fs2/root.

However, this fails with the message Key change error: Key must be loaded. However, when I try to load the key for fs2/root, it fails with the message Key load error: Cannot enter raw keys on the terminal. I never specified any passphrase I could enter anyway.

Is there a way to solve the situation, ideally without copying the data again? I'm using zfs 0.8.3-1 on Devuan ASCII.

1 Answer 1

2

The solution for me was to explicitly set the key location to the key file with zfs set keylocation=.... Then the key could be loaded. Letting the filesystem inherit the encryption settings from the parent by doing zfs change-key -i then also worked. :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .