0

I have tried using 3 different identifiers to mount my partition at /dev/sdb1 to /mnt/drive2, but every time I boot it doesn't seem to work and I have to mount it manually. I am connected remotely so I don't know console output during the boot process. It is a GPT drive and has only one partition of type ext4.

Here's my /etc/fstab:Screenshot of /etc/fstab

The last three lines are my attempts to mount the same partition with PARTUUID, UUID, and the /dev/sdb1 path. None of them worked. Curiously enough, my NTFS partition mounts successfully.

I'm running Arch Linux.

1

please do mount -a and if there is any error it will be printed to terminal.

Also by doing dmesg | grep "sd[a-z]" and dmesg | grep "mount" you can investigate mount errors during boot after booting your linux.

| improve this answer | |
  • Thanks to you, I found the error! gid shows up as an unrecognized mount option. According to this answer, ext filesystems don't support options like gid. Thank you! – Saksham Chawla Apr 18 at 18:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.