I have 5.5 installed on some servers. Now I need to upgrade it to 5.6. I did it by using RedHat 5.6 DVD media using GUI.

But my question is: can this be done without restarting the server and booting from DVD while I'm logged in and the 5.5 session is running? Can this be done on the command line, using the media which I inserted into the DVD drive?

Action taken based on Matteo Instructions

  1. Mounted Redhat media on */media/RHEL_5.6 i386 DVD/Server*
  2. created file in /etc/yum.repos/dvd.repo
  3. Then run this command rpm -ivh createrepo-0.4.blahblahblah.el5.noarch.rpm
  4. Then I tried to run this command createrepo /media/RHEL_5.6 i386 DVD/Server

And terminal slapped back with this error

Error: Only One Directory allowed per run

Normally i copy the RPMs from /media/RHEL_5.6 i386 DVD/Server to /RPMS directory then i run this command createrepo /RPMS and it work. So tell me what to do now.

Action Two

inserted the lines in dvd.repo

name=Red Hat Entp Linux $releasever -$basearch - dvd
baseurl=file:///media/RHEL_5.6 i386 DVD/Server/

and when I used the command

Yum clean all

it gave me error

Options Error: Error Parsing 'file:///media/RHEL_5.6 i386 DVD/Server/ URL must be http, ftp, file or https not ""

  • Mods is it possible to move this question to Super User Forum. Because im not getting any reply
    – OmiPenguin
    Dec 10, 2012 at 12:09
  • 3
    You might have to wait a little bit more than one hour before beginning to complain about missing answers ...
    – Matteo
    Dec 10, 2012 at 12:25

3 Answers 3


You must backslash spaces in your path to the mounted Red Hat DVD. It must be:

createrepo /media/RHEL_5.6\ i386\ DVD/Server

instead of yours

createrepo /media/RHEL_5.6 i386 DVD/Server


Options Error: Error Parsing 'file:///media/RHEL_5.6 i386 DVD/Server/ URL must be http, ftp, file or https not ""

tells you exactly the same.

  • It said Directory /media/RHEL_5.6\ i386\ DVD/Server must be writable. I mounted the ISO image on /media
    – OmiPenguin
    Dec 11, 2012 at 14:35
  • Issue the createrepo command with the -o option and point the /tmp dir e. g. to set the output directory (useful for read only media, as man page says).
    – Gevial
    Dec 11, 2012 at 15:40
  • Ok i did this createrepo -o /media/Rhel_5.6\ i386\ DVD/Server/ but it said Must Specify a directory to Index and open the man page. And i didnt understand this /tmp u mentioned because there is nothing in /tmp and RPMS are on RedHat media
    – OmiPenguin
    Dec 12, 2012 at 7:24
  • Please try createrepo -o /tmp /media/Rhel_5.6\ i386\ DVD/Server/
    – Gevial
    Dec 12, 2012 at 10:01

Minor releases can be upgraded with the yum command:

yum upgrade

If you want to use the files on DVD you will need to define another local yum repository in /etc/yum.repos.d/ (e.g., dvd.repo):

name=Red Hat Enterprise Linux $releasever - $basearch - CD

Substitute the baseurl with the mount point of the DVD

  • Dear I have updated the question based on your instructions and found error please have a look. Waiting for ur advice
    – OmiPenguin
    Dec 10, 2012 at 13:42
  • I don't have a RedHat DVD at the moment. Are you sure that you need the createrepo command? And in any case you will not be able to run createrepo on a DVD as it is mounted as read-only.
    – Matteo
    Dec 10, 2012 at 13:46
  • Dear This time I just did it without initializing RPMS using createrepo and still got error.Please look Action Two
    – OmiPenguin
    Dec 10, 2012 at 13:57

Try mounting your CD/DVD at the mount point like /mount/cdrom, which doesn't contain whitespaces

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.