2

I wanted to install kde plasma, so I followed the next steps:

pacman -S xorg-server xorg-apps xorg-xinit xterm
pacman -S xf86-video-nouveau
pacman -S plasma-meta kde-applications-meta
pacman -S sddm
systemctl start sddm.service

But when i run systemctl start sddm.service to start KDE plasma in the login screen doesn't apper the mouse but it's there because I can move the profile the mouse seems invisible on the other hand when I type the password and enter I have a black screen but this time I can see the mouse.

enter image description here enter image description here How i can solve it?

Btw i installed gdm and works why kde plasma not??

Thx.

2
  • (I've never run Arch+KDE in VirtualBox, I may be not aware of well known issues). Have you tried switching to a different tty (sending e.g. Ctrl+Alt+F2 to the VM) and querying the logs (journalctl)?
    – fra-san
    Apr 16 '20 at 19:58
  • ...and/or Xorg's logs in /var/log.
    – fra-san
    Apr 16 '20 at 20:36
0

Install VirtualBox Guest Packages - virtualbox-guest-utils and xf86-video-vmware. It may also be needed - virtualbox-guest-dkms.

And also load VBox modules in the system - modprobe -a vboxguest vboxsf vboxvideo

Read more here:

https://wiki.archlinux.org/index.php/VirtualBox/Install_Arch_Linux_as_a_guest#Install_the_Guest_Additions

https://wiki.archlinux.org/index.php/VirtualBox/Install_Arch_Linux_as_a_guest#Load_the_VirtualBox_kernel_modules

0

Don't know if this resolves the OP's issue (as I had mouse control even at the login screen and they noted not having the issue using GDE), but this simple fix resolved my similar issue anyway (black screen after login).

I realized I hadn't setup a user home directory, or had set /home as the user home directory.

Therefore, setting up a user-owned home directory and then restarting resolved the issue for me. Either simply by useradd -d $user (note the -d), or manually creating a new user directory, transferring ownership, and then setting the user home directory setting:

cd /home
mkdir $user
chown $user:$group ./$user
usermod -d /home/$user $user

After a reboot, I was able to get a successful login

0

If you're using a kernel package newer than 5.6, install virtualbox-guest-utils, if you're using 5.6 or older, you need to install virtualbox-guest-dkms, along with the headers needed for your kernel.

Then, you need to enable and start vboxservice.service.

You do not need xf86-video-nouveau.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.