0

An odd wifi problem here on Ubuntu 19.10 on a Dell XPS 15, with an Intel AC 9260 card. Normally it's rock-solid, and stays connected for days at a time. This includes multi-GB transfers up and down over http, ftp, smb,etc.

However when I run mbsync (http://isync.sourceforge.net/mbsync.html) it frequently (several times a day) drops out. By 'drop out' here I mean, all transfers time out. The wifi appears connected to the base still, but I can only get further transfers happening by disconnecting and reconnecting.

There's nothing very instructive in the logs at the time:

Apr 16 14:21:08 bamboo mbsync[22095]: Socket error on imap.purelymail.com (18.204.123.63:993): timeout.
Apr 16 14:21:08 bamboo systemd[3322]: mbsync.service: Main process exited, code=exited, status=1/FAILURE
Apr 16 14:21:08 bamboo systemd[3322]: mbsync.service: Failed with result 'exit-code'.

Dmesg reveals the following but I'm not sure if it's simultaneous with the above:

wlp59s0: deauthenticating from 10:b1:f8:b4:57:be by local choice (Reason: 3=DEAUTH_LEAVING)

On the face of it I don't imagine mbsync can actually cause the problem (or can it?). It's running as a user service under systemd. I am 100% sure that mbsync at least triggers the issue (because it never occurs otherwise, no matter how much I stress the network).

Appreciate any pointers or avenues for investigation as I'm stumped.

1 Answer 1

0

I've found a solution, if not an answer.

Given that mbsync seemed to be uncovering some latent instability in my wifi connection, I decided to go stepwise through all the sources of potential instability I could think of.

The first one I tried was to switch my wifi base station from wide to narrow (20Mhz) channel, just to reduce the chance of interference (it's a 2.4Ghz radio).

I could tell within a couple of hours that this had fixed the problem, as mbsync runs had been breaking the connection very frequently.

I'd still be interested to hear, if someone happens to read this who knows about this stuff, why mbsync would trigger this problem, when no other network usage does.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .